Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Returning player needs help
05-29-2012, 11:05 AM
Just got back to the game after being away for awhile ive noticed that all my beam weapsons don't do jack to the enemy npcs so ive had to basicly fight useing torpeods that take forever. i upgraded all my weapsons and consoles for my current level but it didnt change anything. i am eng on a crusier if anyone could tell me what im doing wrong that would be wonderful
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-29-2012, 11:55 AM
I would hazard a guess that your power level is set to something other than weapons.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
05-29-2012, 01:27 PM
Yeah definitely check your power levels. Also, I don't know how long you've been away but there was a forced respec on skills. You need to put points into all your skills again because they changed the skill tree. That could also be why you're feeling weak.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
05-29-2012, 01:55 PM
If you are an eng in a cruiser then take a look at this thread. It should help you get going.

http://forums.startrekonline.com/sho...ragon+flagship
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
05-29-2012, 09:37 PM
Quote:
Originally Posted by BDS
I would hazard a guess that your power level is set to something other than weapons.
is the power lvl something other than the 4 things like sheilds attack equal and speed?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
05-30-2012, 06:19 AM
Also my beams do nothing to enemy sheilds i got enough points in space comabt stuff figure it do something
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
05-30-2012, 06:38 AM
Yeah, your power levels are those, and should always be in 'attack' for the most part.
What rank are you, what weapons do you have on your ship (type and MK) and how rare are they?
If your power level is set into something else other than Attack, then that was most likely your problem.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
05-31-2012, 06:33 AM
im lvl 45 always in attack all weaps are ether blue or green and are allare ethier lower or upper adm. my beams arn't doing any dmg won't take down sheilds nothin
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
05-31-2012, 07:38 AM
What ship are you using? What exactly are your power levels? How many beams are you using? What bridge officer abilities are you using?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
05-31-2012, 08:52 AM
I had that problem, after i did not play for 2 updates. I just bought new weapons, and used them.
When I tried the old ones again, they were working fine.

They were antiproton, won through stf's and spending dilithium. There was no way I was going to just sell them.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:37 PM.