Survivor of Romulus
Join Date: Jun 2012
Posts: 993
# 31
06-20-2012, 11:34 PM
Quote:
Originally Posted by centersolace View Post
Alright, the so the new forums suck. Instead of just griping, let's do something constructive while we grip and make a list of every single reason we hate the new forums. Hopefully it will not fall on deaf ears.

So far we have:

1. The white GUI on black background is garish and downright painful to look at.
2. The buttons are all artifacty and ugly.
3. The quote buttons are at the top instead of the bottom of the posts. (why?)
4. The header, while pretty, is too damned big.
5. Signatures seem to be broken and more constricting.
6. When editing a post, it automatically goes into quick reply.
7. Quick Reply doesn't work, giving poster "No thread specified" error message.
8. Followed threads and mail are unavailable.
9. The "Top" button is no longer available.
10. No more "Hotlinking" threads to your signature. Now you need to "Bump" them instead.
11. A post counter. Let the Whoring begin!
12. No more "location" status? Awe..... :frown:
13. The Dev tracker appears to be broken.
14. Why are the thread buttons so big? The font hasn't changed.
15. Conversely, why are the smilies so small?
16. All of our previous posts are now attributed to the "Archive Post" user, rather than our accounts.
17. Many posters have been rendered unable to use their their original name.
18. Our names cannot use Caps.
19. BBCode is disabled in signatures (would be nice to be able to style text there)
20. Smileys and forum buttons are anti-aliased to white instead of black.
21. There is no "you have posted in this thread" marker when you view "Today's Posts"
22. There is no easy way to "find all posts by X person" (a tool I used to track threads I posted in, and see responses.)
23. Stock avatars are not diverse enough to really identify with
24. When the signature is changed, it doesn't change on all of our old posts and replies. Just on ones after you changed it.
25.When subscribing to a thread, the redirection page is a white background with a small black box of text in the middle.
26. The Galaxy Class in the header is the old one, rather than the one currently in game.
27. Can't see what threads you've posted in anymore (posted in icon)
28. Can't see what threads devs have posted in anymore (dev icon)
29. The bullet list feature does not work (or is unstyled)
30. (Neither does the Paragraph feature)
31. The 'Dominion' Avatar is spelled 'Dominian'
32. Forum PMs aren't integrated with in-game PMs / Mail. Can't check in Core Connect either.
33. Forum searches return a database error.
34. Quote, Multi-Quote, etc, buttons are misaligned.
35. Facebook now auto-links. GL with privacy.
36. No warning as to forum and infrastructure migration
37. If all these changes weren't enough, you also have to learn PWE's Core connect (with a completed different avatar and an Achievement system irrelevant to STO)
38. Nothing on Core Connect functions with STO, including Friends and Guilds (Fleets)
39. Finding any of your fleet mates and friends in the new forums is an exercise in futility, given all the changes to forum handles and friends lists.
40. No "Report to Moderator" function (none at all; start posting whatever flame wars and questionable URLs you want)
41. (No basic forum rules either.)
42. NO CUSTOM AVATARS??!?!?! WTF?!?!?!

Feel free to contribute your gripes, complaints, irritations, pet peeves, sorrows, woes, pains, grumps, indispositions, infirmities, kvetches, murmurs, mutterings, discontentment, objections, and yammerings. I will update this post as they come in. :wink:



well done sir this is what we want make it so!

ps the white really sucks anyone esle getting head aches
Former PWE Community Team Lead
Join Date: Jun 2012
Posts: 9,046
# 32
06-20-2012, 11:34 PM
Quote:
Originally Posted by darkstarkirian View Post
Then why don't you sticky it then?
This is the "Star Trek Online" discussion forum, and this thread is really not about STO. It's about the forums. I didn't move it to General Feedback because I'm okay with this saying in here so it's a little more visible and players can add other "problems" they are seeing.

Cheers,

Brandon =/\=
Brandon "BranFlakes" Felczer | Former Community Team Lead for Perfect World Entertainment
Career Officer
Join Date: Jun 2012
Posts: 206
# 33
06-20-2012, 11:56 PM
#?. Usage of the phrases "New Posts" and "Today's Post" (upper left near "your" avatar) is inconsistent. If both links have the same function, they should say the same thing.

#?. Breadcrumbs links at the top of the forum section say "Star Trek Online > Information and Discussion > Star Trek Online Discussion" (for example). The first breadcrumb should say "Star Trek Online Forums", since that link does not actually lead to the main STO site.
Username: PodSix
Join Date: 11/09/2009
Fleet: None

Last edited by podsix; 06-20-2012 at 11:58 PM.
Captain
Join Date: Jun 2012
Posts: 744
# 34
06-20-2012, 11:56 PM
I don't see any way to send forum PMs from a thread. I have to go to my private messages section, then copy / paste the name, then send it...? Is that how I'm supposed to send a forum PM? Because that seems like an issue.
Join Date: July 29 2008
Super Moderator
Join Date: Jun 2012
Posts: 2,728
# 35
06-21-2012, 12:09 AM
An issue I've run into -

When you click Edit for your post and it does the in-line editing if you hit cancel it redirects you to the Invalid thread specified page.
Volunteer Community Moderator for the Star Trek Online forums
My views may not represent those of Cryptic Studios or Perfect World Entertainment
If you wish to speak to someone on the community team, file a community support ticket here, as we are not able to respond to PMs regarding moderation inquiries.
Contact: Twitter | Line Messenger: askray113
Lt. Commander
Join Date: Jun 2012
Posts: 243
# 36
06-21-2012, 12:10 AM
Quote:
Originally Posted by askray View Post
An issue I've run into -

When you click Edit for your post and it does the in-line editing if you hit cancel it redirects you to the Invalid thread specified page.
Actually almost every edit action has a chance to proc a 404; it's infuriating. Even clicking 'save' on the inline edit results in "No Thread specified. If you followed a valid link, please notify the administrator."
_____________________________________________


I used to be able to play STO, but then Season 9 happened. | Join Date: Dec 2009
1000 Paper Cuts for Star Trek Online
Super Moderator
Join Date: Jun 2012
Posts: 2,728
# 37
06-21-2012, 12:16 AM
Quote:
Originally Posted by robertcrayven View Post
Actually almost every edit action has a chance to proc a 404; it's infuriating. Even clicking 'save' on the inline edit results in "No Thread specified. If you followed a valid link, please notify the administrator."
Hrm haven't run into that one yet, lucky me I guess heh.
Volunteer Community Moderator for the Star Trek Online forums
My views may not represent those of Cryptic Studios or Perfect World Entertainment
If you wish to speak to someone on the community team, file a community support ticket here, as we are not able to respond to PMs regarding moderation inquiries.
Contact: Twitter | Line Messenger: askray113
Lt. Commander
Join Date: Jun 2012
Posts: 243
# 38
06-21-2012, 12:19 AM
Quote:
Originally Posted by askray View Post
Hrm haven't run into that one yet, lucky me I guess heh.
Yeah, apparently so. The weird thing is that the edit DOES go through, as when I go back to the thread my revised post shows up, but for some reason the 'save' and 'cancel' buttons are borked and dump you into the catchall screen instead of returning you to the thread you were editing in.
_____________________________________________


I used to be able to play STO, but then Season 9 happened. | Join Date: Dec 2009
1000 Paper Cuts for Star Trek Online
Career Officer
Join Date: Jun 2012
Posts: 2,863
# 39
06-21-2012, 12:25 AM
Here is something - it seems an unenumerated list doesn't show any list marks, even when nesting lists. And the enumerated list formatting seems borked.

Enumerated List with a nested element
  1. A
  2. B
  3. C
    1. C1
    2. C2

Unenumerated List with a nested Element
  • D
  • E
  • F
    • F1
    • F2

"Best" thing about it - there are two editing modes (let's call them preview and code) - one shows the lists nicely formatted, the other shows the code behind it. The preview-editing mode preview has nothing to do with how the post actually looks later.

Mustrum "My Posting Style just got nerfed" Ridcully
Lt. Commander
Join Date: Jun 2012
Posts: 243
# 40
06-21-2012, 12:29 AM
Quote:
Originally Posted by mustrumridcully0 View Post
Here is something - it seems an unenumerated list doesn't show any list marks, even when nesting lists. And the enumerated list formatting seems borked.

Enumerated List with a nested element
  1. A
  2. B
  3. C
    1. C1
    2. C2

Unenumerated List with a nested Element
  • D
  • E
  • F
    • F1
    • F2

Mustrum "My Posting Style just got nerfed" Ridcully
Hey, at least a certain well-known poster's beloved italics are still working so he can make our eyeballs bleed with his bizarre emphasizing style. :biggrin:
_____________________________________________


I used to be able to play STO, but then Season 9 happened. | Join Date: Dec 2009
1000 Paper Cuts for Star Trek Online
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:54 PM.