Career Officer
Join Date: Feb 2013
Posts: 3
Bought 2 $20 PWE prepaid cards (like I've been doing lately) from my local GameStop.

Went to charge the Zen like usual...thought it was odd that I couldn't log in to charge Z at first, but didn't think anything of it.

Finally got logged in to the redemption page for PWE's prepaid cards, and entered the 1st code...the system seemed to time out (clock-spin), then didn't really do anything, so I tried to re-enter the number again, and it said the code it was "already redeemed".

"Ok, I thought...I got my Zen. System must be running slow".

Same thing for the 2nd card...I logged into the game to go spend my Zen...and nothing. No Z added to the game. Checking for my purchases again, the 2 cards don't show up in my purchase history, and now the purchasing system says they're redeemed.

So, I'm apparently out $40, 4,000 Zen, and am on the forums trying to get PWE to help because the ticket system doesn't work and goes to a broken link that won't load.

Glad I refuse to use my credit card here, which is why I buy prepaid cards...which I'm now out $40 because apparently the Zen Charging system is bugged and I was bright enough to debug it for them by handing them $40 in exchange for nothing.

I'd like my 4,000 Zen, but I'm thinking I'm not going to be getting that back...and so I'm not spending any more money here...and I'm a adult that has money to spend on this game, if PWE/Cryptic look at my purchase history. I wasn't shy about dropping cash here...and now, why bother?
Starfleet Veteran
Join Date: Jun 2012
Posts: 23
# 72
06-14-2014, 11:56 PM
Well Cryptic? No answer... just going to ignore this as another problem to irritate the loyal fans, eh? Nice way to alienate your own customer base, just saying.

I wish I had seen the post by kommander1988, and everyone before this first, but lesson learned I guess. I think its obvious to everyone that this nightmare you call Arc mishandles and dead links attempts to get help and none apparently can be found on the forums either. For years now, I had no issues with the PWE site to redeem cards. But now, Arc took a perfectly workable system for the company's prepaid cards and busted it. So, tell me again how wonderful Arc is and how it's so easy and efficient to use and why we would want to install it on our systems... yeah... right...

I have two worthless PWE cards that say otherwise.

Now that being said, is their any chance someone with any sort of "title" can come in here and tell us what can be done to fix this and get our zen?

Last edited by paulbowman; 06-15-2014 at 12:49 AM.
Starfleet Veteran
Join Date: Jun 2012
Posts: 23
# 73
06-20-2014, 08:40 PM
Quote:
Originally Posted by paulbowman View Post
Well Cryptic? No answer...
Not yet...
Starfleet Veteran
Join Date: Jun 2012
Posts: 23
# 74
06-25-2014, 05:46 PM
Quote:
Originally Posted by paulbowman View Post
Not yet...

Still no response... others posting similar problems...
Career Officer
Join Date: Dec 2013
Posts: 1
# 75 zenny
06-27-2014, 02:07 PM
how did i buy zenny to give to a friend so he can buy stuff
Starfleet Veteran
Join Date: Jun 2012
Posts: 23
# 76
06-30-2014, 10:42 PM
I don't know... did you use a PWE card? Did you use a debit card? Did you twitch your nose like Bewitched?

Your commentary is not helpful to those of us who lost money.
Community Moderator
Join Date: Jun 2012
Posts: 2,552
# 77
07-02-2014, 11:16 AM
Folks, asking for fixes, GM's etc in a thread randomly isn't going to get you anywhere.

If you have an issue with anything to do with ZEN your only option is to contact support. If you cannot use http://support.arcgames.com you can e-mail customerservice@perfectworld.com on the email thats attached to the account and they can look into things for you.

Beyond that there is no other options.
Volunteer Community Moderator for the Star Trek Online forums
My views may not represent those of Cryptic Studios or Perfect World Entertainment
If you wish to speak to someone on the community team, file a community support ticket here, as we are not able to respond to PMs regarding moderation inquiries.
Contact: Twitter | Line Messenger: askray113
Starfleet Veteran
Join Date: Jun 2012
Posts: 23
# 78
07-05-2014, 09:17 PM
I appreciate your input on this issue, hopefully it will help solve the issue with the email.

I will try emailing as the site is still not allowing access to customer service, let's see what happens. I'll post accordingly when I get answered.

If this works, if... maybe these instructions should be stickied?
Starfleet Veteran
Join Date: Jun 2012
Posts: 23
# 79
07-09-2014, 12:05 AM
Fixed in 27 hours from request being sent in... and on a weekend no less.

Now that is impressive Customer Service. I don't know why the ARC site is still not linking but the email worked better than expected. I recommend this be stickied for all to reference in the future.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:12 AM.