Lieutenant
Join Date: Jul 2012
Posts: 61
# 1 Shield regeneration...
07-07-2012, 12:51 PM
This may have been mentioned before and as such I apologise if that is the case...

Basically I have been playing the game since open beta and ive finally decided that theres something definately wrong and instead of just living with it I figured id ask here...

When in combat my shields take damage (like everyone else), however I have noticed that the shields will not regeneration every 6 seconds like it is 'supposed' to and indeed even once combat has stopped my shields still do not regenerate. The only way I can get my shields to regenerate is to use powers like EPtS and TSS.

I have tried playing around with different shield types and all have the same issue. They take damage, never regenerate without the use of the above powers.

Anyone else noticed this as an issue and if not what am I missing/doing wrong?
Commander
Join Date: Jun 2012
Posts: 265
# 2
07-07-2012, 05:38 PM
At 25 power they will not regenerate. Also if you are cloaked.
Lieutenant
Join Date: Jun 2012
Posts: 66
# 3
07-07-2012, 06:12 PM
Well if you've gotten far enough in the game to Vice Admiral Lv 50 why not just earn 5 Encrypted Borg Data Chips then go to DS9 and Equip Your StarShip with the Borg Regenerative Shield Array ? cause i assure that if your up to that level and Rank right now and you do that you won't regret it thats for sure
Empire Veteran
Join Date: Jun 2012
Posts: 6,764
# 4
07-07-2012, 07:01 PM
If your shields are taking constant damage that facing will not regenerate.
It does not explain why undamaged facing do not regenerate very fast when not under fire.
Also most shields regen to low amounts to make difference, especially under fire without EPTS or TSS
Richard Hamilton (1975-2014)
goodbye good friend. We will see you in the DMZ in the sky oneday, save a shot for us.
Career Officer
Join Date: Jun 2012
Posts: 514
# 5
07-07-2012, 07:54 PM
Quote:
Originally Posted by bitemepwe View Post
If your shields are taking constant damage that facing will not regenerate.
It does not explain why undamaged facing do not regenerate very fast when not under fire.
Also most shields regen to low amounts to make difference, especially under fire without EPTS or TSS
Damage taking shields always regenerate...


For the OP, the only thing that can explain it if you use a very, very bad shield with really, really low regen rate, and / or a shield power level of 25~ish.

for any other situation, like cloak, etc, sector space, the shield facings do not even show so thas kinda logical in those cases the shields are graphically shown as 0. (No blue/red filled)
Captain
Join Date: Jun 2012
Posts: 2,007
# 6
07-07-2012, 08:45 PM
Actually I noticed that my shield isn't regenerating as it was since the last patch.

Normally when I come out of combat, I flip over to the shield preset so that's at 125.

The shields just sit there until I activate a boff power as well.
---
Took 20 minutes to get that screencap and her arm is still doing through the armrest
Dr. Mike's Steak Dinner

35 Starbase Projects done. 715 Projects remaining
Starfleet Veteran
Join Date: Jun 2012
Posts: 794
# 7
07-07-2012, 08:55 PM
I've actually noticed after combat switching full power to sheilds doesn't do much for recharge rates sometimes either, there is something not right there. Also noticed on ground combat sometmes sheilds won't regen without a sheild generator to sit under.
Lieutenant
Join Date: Jun 2012
Posts: 97
# 8
07-07-2012, 10:19 PM
Quote:
Originally Posted by mikewendell View Post
Actually I noticed that my shield isn't regenerating as it was since the last patch.

Normally when I come out of combat, I flip over to the shield preset so that's at 125.

The shields just sit there until I activate a boff power as well.
I have seen this aswell. Mainly on my Escprts and Escprt carrier. my Atrox with the Borg set is Fine. Anyother Sheilds dont recharge!
Captain
Join Date: Jun 2012
Posts: 1,395
# 9
07-07-2012, 10:39 PM
I've seen this happen sometimes but because I've never really tested it I can't say if it's an actual phenomenon or not. Number-wise, shield regen is extremely low, even with a 3 x [Reg] Regenerative Array and 125 shield power.
Empire Veteran
Join Date: Jun 2012
Posts: 6,764
# 10
07-08-2012, 09:57 AM
The only time ive seen a shield facing regen under fire is when tacteam, EPTS or TSS is being used.
When just distributing shield power normally i often find the shields are outpaced by incomming damage, even at 125 power.
Ive even noticed on occassion that EPTS and a ShieldBatt wont be fix shields that have been debuffed by debuff abilities.
Richard Hamilton (1975-2014)
goodbye good friend. We will see you in the DMZ in the sky oneday, save a shot for us.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:52 PM.