Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Ensign
Join Date: Aug 2012
Posts: 4
I'm new to the game so I'm not sure if this is actually intentional or a bug. I'm in the Romulan storyline quests right now and whenever I fight their ships they all tend to fire heavy plasma torpedos at me. However, half the time those torpedos fly half way to me and then do a 180 and either hit the ship that fired it or one of their allies. I'm playing as a science officer with a olympic class ship and I don't have a sensor jamming ability.
Starfleet Veteran
Join Date: Jun 2012
Posts: 240
# 2
08-23-2012, 10:00 PM
Hi there, and welcome to Star Trek Online.

The Romulans are a highly aggressive people these days and the xenophobia of certain groups knows no bounds after the shattering of their Empire. Internecine squabbles and infighting... You might think that xenophobia and suspicion has permeated even their weapons systems so that their own heavy weapons don't trust them!

Though more likely, what you are seeing is a bug in torpedo targeting logic. I have seen it happen as well as members of my own fleet. It is a rather comical thing to witness and has been going on for long enough that one would think Cryptic should have caught it (or been notified of it) by now and fixed it.

The Artist Formerly Known As Nikotaka ][ Join Date: Jan 2010
"Can anyone remember when we used to be explorers...?"
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:49 AM.