Career Officer
Join Date: Jul 2012
Posts: 574
# 1 Sony VAIO with nVidia GPU help
08-18-2012, 06:40 AM
Hey all.

I have a Sony VAIO laptop with a nVidia GeForce 8400M GT graphics chip.

I can play STO on this laptop, which I use when I'm on the road, and it plays well enough to do basic stuff.

But I would like to to update the video driver, but it appears that Sony has not updated the driver for this laptop for Win7. Sony's latest driver is dated from 2009.

nVidia's website was no help either, as anything they have for this GPU is not compat with the laptop.

Anyone know where I can get an updated driver for this, that will run on this Sony laptop?


Thanks all!
Captain
Join Date: Jun 2012
Posts: 745
# 2
08-18-2012, 07:03 AM
Quote:
Originally Posted by rifter1969 View Post
Hey all.

I have a Sony VAIO laptop with a nVidia GeForce 8400M GT graphics chip.

I can play STO on this laptop, which I use when I'm on the road, and it plays well enough to do basic stuff.

But I would like to to update the video driver, but it appears that Sony has not updated the driver for this laptop for Win7. Sony's latest driver is dated from 2009.

nVidia's website was no help either, as anything they have for this GPU is not compat with the laptop.

Anyone know where I can get an updated driver for this, that will run on this Sony laptop?

Thanks all!
With laptops I don't necessarily recommend going straight to nVidia for the drivers.

This is a good site to start with: http://laptopvideo2go.com/

Their drivers are on the right and they have a forum.


Good luck.
__________________________________________________
"I weary of the chase. Wait for me. I shall be merciful and quick."

Last edited by beezle23; 08-18-2012 at 07:09 AM.
Career Officer
Join Date: Jul 2012
Posts: 574
# 3
08-18-2012, 01:59 PM
Thanks.

I did come acroos that site in my searches. i did find drivers that they had for this particular graphics chip, but everything looked like it was around the same date as Sony.
Starfleet Veteran
Join Date: Jun 2012
Posts: 64
# 4
08-18-2012, 11:37 PM
Quote:
Originally Posted by rifter1969 View Post
Hey all.

I have a Sony VAIO laptop with a nVidia GeForce 8400M GT graphics chip.

I can play STO on this laptop, which I use when I'm on the road, and it plays well enough to do basic stuff.

But I would like to to update the video driver, but it appears that Sony has not updated the driver for this laptop for Win7. Sony's latest driver is dated from 2009.

nVidia's website was no help either, as anything they have for this GPU is not compat with the laptop.

Anyone know where I can get an updated driver for this, that will run on this Sony laptop?


Thanks all!
Try the Geforce 8M series? http://www.geforce.com/drivers
-------------------------------------------------------------
President of Alpha Solaris, a Federation fleet.

I used to be Sinsofasolarempire
Career Officer
Join Date: Jul 2012
Posts: 574
# 5
08-20-2012, 02:13 PM
Quote:
Originally Posted by sinsofanempire View Post
Try the Geforce 8M series? http://www.geforce.com/drivers

Thanks I'll take a look at site form my laptop.
Career Officer
Join Date: Jul 2012
Posts: 574
# 6
08-27-2012, 03:16 PM
Quote:
Originally Posted by sinsofanempire View Post
Try the Geforce 8M series? http://www.geforce.com/drivers
I tried that site, no luck.

*sigh* just have to deal with it until I can get a newer laptop
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:50 PM.