Lieutenant
Join Date: Nov 2012
Posts: 31
I tried subscribing, it wont let me logon to site, say enable cookies, which I did, still gives error.
I can logon to game and forum with no problems.
Making it a headache to pay.
Ensign
Join Date: Jul 2012
Posts: 12
# 2 Me too
07-06-2014, 05:49 PM
I'm having the problem, my cookies are enabled I guess they don't want our money.
Ensign
Join Date: Oct 2013
Posts: 22
# 3
07-06-2014, 06:21 PM
Changing browsers is not a certainty. I know this all too well myself as I have tried using literally every browser available, including one that normally only the military uses or has access to and still no dice. From what I can tell the problem is, as mentioned above, a problem with the handshake protocols but it seems to be region specific as well not simply browser based. It sucks too because I was all set to finally cave and sign up for a lifetime sub. Something I normally would never do on ANY game period. Regardless I still love STO with or without the advantages of a sub.
Lieutenant
Join Date: Nov 2012
Posts: 31
# 4 still trying
07-07-2014, 12:41 PM
Changed browser to google chrome after trying all of supports suggestions. Did not get to the cookie message yet, got to code auth, no matter what I enter it will not login, Im using the same lonon for game and forum and I can logon there, it might be that stupid letter box tried small letters and caps no luck.
They really don't want my money, any game that makes it this hard to pay wont last long, paying might be a bad idea.
Starfleet Veteran
Join Date: Jun 2012
Posts: 480
# 5
07-07-2014, 12:56 PM
Quote:
Originally Posted by grob44 View Post
got to code auth, no matter what I enter it will not login, Im using the same lonon for game and forum and I can logon there.
Use the auth. code you got from email
Bone1970 & Bone trader don't believe in a no-win senario, Kirk's protege. Fed Tac's. BNE Fed Sci.
Bag of Bones & Bone Ugly don't believe in a no-win senario, Kirk's protege. Rom/Fed Tac. Bone & Bone2 don't believe in a no-win senario, Kirk's protege. KDF Eng's.
Warning: Not a native English-speaker, sorry if my English sucks.
Lt. Commander
Join Date: May 2013
Posts: 177
# 6
07-08-2014, 01:38 AM
Had the same issue, kept getting the cookies message in IE.

Tried Firefox and got the same.
Tried safari and it wouldn't even load the page properly.
Finally tried Chrome and it let me log in, filled out the form for lifetime hit submit and it stalled with an error saying it couldn't connect to PayPal part and wouldn't go any further (I know PayPal was working fine as I'd paid some bills shortly before hand).

Gave up in the end went out and spent the 147 I had borrowed and put aside for lifetime on beer.

What really annoys me is transactions work fine if I buy Zen, Transactions work fine if I sub/resub (tested that too) but it just completely screws up when trying to buy the LTS.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:46 PM.