Ensign
Join Date: Jul 2012
Posts: 2
# 1 torpedo damage before visual?
10-05-2012, 06:56 PM
So, why is it that I often am destroyed in space before an actual torpedo hits me? I feel like I'm being robbed of the opportunity to defend myself.

I'm sure this has been discussed elsewhere, but, any thoughts?
Captain
Join Date: Jun 2012
Posts: 11,103
# 2
10-05-2012, 07:09 PM
Probably lag. :\

At least it isn't as bad as UCGO. Damage happens instantly whether the target is four feet away or 4000.
http://i1151.photobucket.com/albums/o633/centersolace/189cux9khvl6ojpg_zpsca7ccff0.jpg

So inhumane superweapons, mass murder, and canon nonsense is okay, but speedos are too much for some people.
Career Officer
Join Date: Jun 2012
Posts: 3,638
# 3
10-05-2012, 07:21 PM
I noticed a lot of battle lag while playing yesterday (for the first time in over two months I might add)...

That's something I've never really had a problem with before.

I'm running on a Pent. Dual-Core E5300 (2.60GHz x2) with 6 GB of RAM and a High-speed Internet connection...

Also running WIN 7-Pro (64-bit)...

Maybe it's time to upgrade my processor, They have added a lot of new animations to the game powers, that might be what's doing it.
......... DaveyNY ...STO Forum Minion since February - 2009
..............Star Trek Fan since Thursday Sept. 8th, 1966
There are No Longer any STO Veterans... We're Just Minions who have Played the Game for the last 4.75 years.
.......................SARCASM... Just Another Service I Offer...
Career Officer
Join Date: Jun 2012
Posts: 6,416
# 4
10-05-2012, 08:29 PM
Sometimes its lag, but I got a good speed connection and the damage does occur before the visual impact.

Thought they fixed it a long time ago with the Borg torpedoes. Guess it got broke again.
Commander
Join Date: Jul 2012
Posts: 427
# 5
10-06-2012, 10:37 AM
I don't think it's a bug due to how the game handles damage. Like almost any MMO hit or miss is predetermined the instant a weapon fires, even if you use a speed boost skill like Evasive or Ramming Speed you'll still take damage from torpedoes even if the actual graphic doesn't hit you.

It seems like torps have a limited amount of time where they actually display, and if the time expires before it hits it does the damage then instead of just disappearing, which would make more sense. I've hit evasive and been over 30km away from a ship that fired torps at me and still taken the damage. The only thing I've noticed that isn't affected by this is the plasma sphere from the command ships in invasions, but I suspect that's not really an actual projectile.
Ensign
Join Date: Jul 2012
Posts: 2
# 6
10-08-2012, 08:48 AM
Thanks for the insight... although I'd be surprised if this was attributed to lag...

So I guess we just live with this?
Career Officer
Join Date: Jun 2012
Posts: 883
# 7
10-08-2012, 09:40 AM
The invisi borg torpedo was never fixed, it has been there since they broke it all those many moons ago.

Never noticed getting damage before a torpedo hit though, only from the borg torp in stfs.
Career Officer
Join Date: Jun 2012
Posts: 6,198
# 8
10-08-2012, 11:14 AM
Quote:
Originally Posted by darkenzedd View Post
The invisi borg torpedo was never fixed, it has been there since they broke it all those many moons ago.

Never noticed getting damage before a torpedo hit though, only from the borg torp in stfs.
Yeah. Some torpedos (Borg mostly) don't display because there are too many SFX onscreen. Needs fixed. Never has been.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:07 PM.