Ensign
Join Date: Aug 2012
Posts: 8
First of all if I am posting this in wrong place, my apologies. This isn't a bug report but more of an observation from my point.

I had been using Assimilated Subtranswarp Engines for a little while and was happy with them until a fleet member suggested the M.A.C.O. Impulse Engines Mk XI & MK XII were faster overall.

As I snagged a rare engine tech in an earlier STF, I claimed the MK XI engine and put it to the test.

I had been getting the following speeds

Assimilated Subtranswarp Engines - 20.93 and 34.17
M.A.C.O. Impulse Engines Mk XI - 21.43 and 40.81

Both are without any diplomatic immunity or raiding party.

Today I find the speeds of the M.A.C.O. Impulse Engines Mk XI have dropped significantly.

M.A.C.O. Impulse Engines Mk XI - 18.43 and 35.1
That is a drop of 14%

I wonder if this was an intended change and got slipped in under the radar during yesterdays patch.
Lt. Commander
Join Date: Sep 2012
Posts: 150
# 2
10-26-2012, 04:48 AM
Did you respec perhaps and removed points from your driver coil skill?
Also, maybe you had the coil buff from the doff assignment first time you looked.

One thing, BORG engine should improve your common speed in sector space, but MACO is the one you're after if your goal is the high slipstream speed.
Career Officer
Join Date: Jun 2012
Posts: 476
# 3
10-26-2012, 05:10 AM
Yeah, in most normal circumstances the MACO should be slightly slower in sector space, but faster at slipstream, because of the driver coil boost.
Captain
Join Date: Jul 2012
Posts: 2,192
# 4
10-26-2012, 05:12 AM
Did you change engine power settings by a chance ? Looks very slow to me anyway...

Edit: a screw that you meant in sector space

Last edited by dalnar83; 10-26-2012 at 05:17 AM.
Captain
Join Date: Oct 2012
Posts: 918
# 5
10-26-2012, 05:14 AM
i wish the khg engines had the speed boost.. its dumb they dont..
Career Officer
Join Date: Jun 2012
Posts: 688
# 6
10-26-2012, 06:29 AM
Yeah, the MACO engine's a little slower at warp and faster at slipstream, that said, if you did notice a change, it could be your setup, skillwise, or if you're flying an Odyssey, and you removed one or more of the Odyssey consoles where before you used all three, if I don't recall incorrectly you lose a driver coil set-bonus as well.
Reave
Starfleet Veteran
Join Date: Jun 2012
Posts: 2,498
# 7
10-26-2012, 06:38 AM
Actually, looking at your numbers, looks like the Borg engine speed "stuck" when you switched engines and refreshed down to the correct MACO speed. I'd have to check the driver coil bonus on the MACO engine, but that look like about the speed you'd have if you had the driver coil bonus on top of the Borg engine.

Were you by any chance already at full speed when you switched? Did you change maps any time before losing the higher speed?
Ensign
Join Date: Aug 2012
Posts: 8
# 8
10-26-2012, 06:54 AM
Thank you all for the replies.

My driver coil is at 9 and I haven't re skilled. I was using the Chimera Heavy Destroyer and had no driver coil buffs from D'off missions. If I had had them my speed with the Borg engines would have been much faster than the 20.93 I was getting.

My fleet was having a discussion last week on their forum on how to get the most from the tour the galaxy event so I had been flying around Fed space, Sol down to the Eta Eridani Sector Block and making notes of the numbers, coming to a full stop and then swapping engines.
Ensign
Join Date: Aug 2012
Posts: 8
# 9
10-26-2012, 09:25 AM
How embarressing!

It seems I didn't notice that I had DI when I was testing this last week and today.
I have it right now and my speed with the MACO MK XI is back to 21.43 and 40.81 with slipstream drive.

For normal travel, as one poster mentioned, the Borg engine is the fastest but with the slipstream effect, the MACO is (but only by 1 point).
Starfleet Veteran
Join Date: Jun 2012
Posts: 891
# 10
10-26-2012, 09:32 AM
Quote:
Originally Posted by shadsfirehawk View Post
How embarressing!

It seems I didn't notice that I had DI when I was testing this last week and today.
I have it right now and my speed with the MACO MK XI is back to 21.43 and 40.81 with slipstream drive.

For normal travel, as one poster mentioned, the Borg engine is the fastest but with the slipstream effect, the MACO is (but only by 1 point).
At least you had the cajones to come back and fess up to what you did. Most people would have just quit posting and called it a day.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:53 AM.