Ensign
Join Date: Jun 2012
Posts: 16
# 1 Zen points...
11-06-2012, 08:05 PM
Purchased Zen points seven hours ago, still have yet to receive them later. How long does it usually take to disperse it?
Starfleet Veteran
Join Date: Jun 2012
Posts: 1,231
# 2
11-06-2012, 08:07 PM
First time purchase it can take a few hours while they personally validate your purchase. From then onwards in will be instant.
Federation Bushrangers
Federation & Imperial Bushrangers
Looking for an Australian/New Zealand fleet?
Sign up here:
www.bushrangers.net
Career Officer
Join Date: Jun 2012
Posts: 440
# 3
11-06-2012, 08:09 PM
also make sure you have transferred them to sto:holodeck after you have purchased them once transferred they will show up instantly ingame.
Click to visit Subspace-Radio
Twitter | Blog | Original Join Date: Dec 2007 | Gaming Setup | Raptr Profile | Gamer DNA
The opinions expressed in my posts are my own views and do not reflect on any other entity(s) or person(s) I may or may not represent at the time.
Ensign
Join Date: Jun 2012
Posts: 16
# 4
11-06-2012, 08:13 PM
I've purchased before from the same credit card, and it's not showing that it's been completed. I'm just wondering if there's been an influx in buying Zen points at the time I bought it...either way, it's been awhile and I'm getting a bit worred
Career Officer
Join Date: Jun 2012
Posts: 597
# 5
11-06-2012, 08:27 PM
Quote:
Originally Posted by juggernaught92 View Post
I've purchased before from the same credit card, and it's not showing that it's been completed. I'm just wondering if there's been an influx in buying Zen points at the time I bought it...either way, it's been awhile and I'm getting a bit worred
this happened to me as well. told my cc did a reverse transaction got my zen 5 min later. 1 month later after i had to keep e-mailing support they took off the double charge.
Ensign
Join Date: Oct 2012
Posts: 12
# 6
11-06-2012, 11:04 PM
I had the same problem today and it's not my first purchase. It's been about 12 hours and I haven't received my Zen (Not even in my Perfect World wallet). I emailed Perfect world about 10 hours ago and never received a reply that they even got my email. The Perfect World web site show's no sign of my transaction even though Paypal shows that the transaction went through pretty much instantaneously. I am not impressed.

*Edit*
Btw, my first purchase went through without a hitch.
Ensign
Join Date: Nov 2012
Posts: 1
# 7 reviewing
11-07-2012, 12:10 AM
Yesterday I bought 2000 zen points. After 24 hours and still did not get it.
He writes in the status window: Reviewing.
A bank account has not not load, it says the reservation.

I received a confirmation e-mail, but still no zen.
I did not get paid again is not worth anything

Last edited by padrehu; 11-07-2012 at 03:16 AM.
Ensign
Join Date: Nov 2012
Posts: 2
# 8
11-07-2012, 04:58 AM
apparently their servers are having a bit of a hiccup but they promise everything will be straightened out soon. i got this as a reply after making a ticket.

"We are currently experiencing issues with our billing systems which have caused long review times and incomplete transfers for some of our players. Unfortunately, we are unable to investigate these situations further until our systems are fully restored. Our engineering team is currently working to get the billing platform running smoothly again as fast as possible.

We sincerely apologize for the wait time and ask for your continued patience while systems are restored. If your transaction is pending or your ZEN transfer did not award ZEN, please be assured that we will address these issues and appropriately credit accounts and/or award ZEN.

Thank you for your understanding during this technical interruption."
Survivor of Romulus
Join Date: Jul 2012
Posts: 68
# 9
11-07-2012, 05:23 AM
same here - purchased 500 points yesterday afternoon, got the confirmation email from skrills that the transaction was successful -> still on "reviewing".
then i wanted to write a ticket - went to support, contact us -> site not reachable ("too many redirects" jibberish).

i really love perfect world for backing STO, but this (small) problem is driving me nuts right now, since it worked perfectly while cryptic was in charge of it. i know its not that big of an issue, but patience.. well.. patience is not really my middle name.

Last edited by derbock203; 11-07-2012 at 05:36 AM.
Survivor of Romulus
Join Date: Jul 2012
Posts: 68
# 10
11-07-2012, 06:49 AM
my transaction just turned into "completed" and the transfer to STO worked - seems they figured out the serverproblems. thanks pw technicians, cheers.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:40 PM.