Lt. Commander
Join Date: Dec 2007
Posts: 120
For some reason STO has always been too dark on 100% brightness (in-game setting) even though everything else looks fine on my computer, so I've had it at 130% brightness for months now. Whenever I would play, even if I minimized STO (I play in maximized windowed mode) everything else, whether it was another program, my browser, or even my desktop would be correspondingly brighter but it would always go back to my default brightness when I exited STO.

Today for some reason the brightness hasn't gone back to normal after exiting STO. Everything's as bright as it is when I have the game running. If I log onto STO, turn the brightness up or down and then exit, everything still matches whatever brightness I set STO to. How can I get the brightness to go back to normal after exiting the game? Better yet, is there a way to get my in-game brightness to stop affecting everything else while STO is running?

I have Windows Vista 64 bit & a Radeon HD 4850 card. I rebooted after the problem began and immediately got new graphics drivers, but the problem persists. I've also checked the brightness & contrast settings in Catalyst Control Center & they're at normal (0 & 100 respectively).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-03-2012, 12:21 AM
That happens to me when STO crashes. The brightness setting is in fact a gamma correction. My advice is to look online for a gamma reset program or method. I quick search found one for OpenGL programs, so I imagine there's one that'll work for this.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
05-03-2012, 03:15 AM
That was exactly it. I found an option in the Catalyst Control Center. Muchas gracias!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
05-03-2012, 07:29 AM
Games will always do that. I'm not sure why its getting stuck on normal exit. It usually would do that when the game crashes. Another way to clear the issue is to log out and log in on windows (Not shut down).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
05-03-2012, 10:18 PM
The Borg assimilated your computer ... resistance is futile !
Ensign
Join Date: Nov 2012
Posts: 1
# 6 Hello
11-07-2012, 07:42 PM
Hi I've got the same problem described by the original poster. I was playing maybe 4-5 days ago, I accidentally minimized the game, and when I did, the settings from the game for gamma and brightness seemed to transfer to my desktop. Since then I have had someone re-format my computer, and nothing seems to have changed.

Umm, so I'm out of ideas completely. Is it possible that the game wrecked my monitor or graphics card? If not, why did re-formatting the computer not change everything back to normal? It's just an old crappy cathode-tube style Dell 19'' monitor, but up until I played this game, and minimized the screen by accident, things worke3d fine. It ran beautifully, my card temperatures stayed normal, never even had one error or crash. I'm sure I'm missing something here, please help!
Lt. Commander
Join Date: Sep 2012
Posts: 144
# 7
11-08-2012, 05:32 PM
A change that survives a full system reformat is suspicious. I'd think it's unlikely a hardware issue with your card though: those usually manifest in a completely different and fairly distinctive way. If I had to speculate, I'd guess either:

A) Something happened to your monitor around the same time causing you to misattribute the change to something in your system. Your system shouldn't be able to interact with the monitor's own onboard settings, so if something's wrong with the monitor, it won't be fixed by any tinkering you do with the system (and conversely can't have been broken by STO or any other program, but a coincidentally timed monitor issue could trick you into thinking it was system/software issue).

B) Your GPU driver was originally calibrated to something other than the default, and whatever happened wiped it back to default. Reinstalling/reformatting naturally just reinstalls the default settings, so it would appear the same as before the reformat, as if nothing had been fixed.

What kind of GPU card do you have? Your graphics card driver should have the ability to save manual calibration presets. Open you GPU driver, manually recalibrate for your desktop and save as a preset. Then whenever an STO crash or something resets your GPU settings, just go back into the driver app and reactivate your preset. I know AMD Catalyst can do this, at least.

Oh, ahh, this ones a way, waaaay long shot as I'm not sure how it could possibly happen in any way linked to a running app within your OS, but check your BOIS settings to be sure your PC hasn't reverted to using the motherboard's onboard graphics chip instead of your graphics card. Like I say though, that's pretty left field, both in terms of likely cause, and symptoms (it'd probably downgrade your output resolution as well as resetting you color/brightness/gamma calibration, and so would be REALLY noticeable).

Also download and Run Furmark and Futuremark (google 'em) to test your GPU for glitches.

'm not even close to an expert, but I hope that helps.

Last edited by connectamabob; 11-08-2012 at 05:37 PM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:26 PM.