Empire Veteran
Join Date: Jun 2012
Posts: 2,525
# 1 Plasma Cannon Animation
01-09-2013, 02:23 PM
I thought I remembered at one point where this animation with plasma cannons was changed but it looks now that it looks like its shooting big giant neon green squares LOL. Been wondering if it was going to be changed/updated to look more pleasing to the eyes LOL.
Starfleet Veteran
Join Date: Oct 2012
Posts: 1,185
# 2
01-09-2013, 02:49 PM
Quote:
Originally Posted by zeuxidemus001 View Post
I thought I remembered at one point where this animation with plasma cannons was changed but it looks now that it looks like its shooting big giant neon green squares LOL. Been wondering if it was going to be changed/updated to look more pleasing to the eyes LOL.
Are you running low, medium, or high graphics settings? What anti-aliasing level?
Empire Veteran
Join Date: Jun 2012
Posts: 2,525
# 3
01-09-2013, 04:53 PM
Quote:
Originally Posted by shar487a View Post
Are you running low, medium, or high graphics settings? What anti-aliasing level?
High graphics settings and 4x (high quality) anti-aliasing level. I just remember one time plasma and antiproton got updated and then haven't used those types in awhile but now they look like big giant squares shooting out lol.

Edit: Put it on x8 anti aliasing to see if it made it better but from this raptor using romulan xii set its like every other cannon shot looks like a block lol Some of them kinda look like the way AP does except neon green its just at x8 helps some but not enough when it comes to these plasma cannons.

Last edited by zeuxidemus001; 01-09-2013 at 05:00 PM.
Commander
Join Date: Sep 2012
Posts: 255
# 4
01-09-2013, 05:22 PM
Hmm. corrupted texture maybe?
Empire Veteran
Join Date: Jun 2012
Posts: 2,525
# 5
01-09-2013, 06:39 PM
Quote:
Originally Posted by mikearoo View Post
Hmm. corrupted texture maybe?
Pretty much like most of the game lol
Commander
Join Date: Sep 2012
Posts: 278
# 6
01-10-2013, 03:15 AM
I'd try going into options on the launcher and choosing "force verify" to see if something's messed up. I play on pretty much the lowest of the low settings and I see plasma cannons firing as a little "star" shape, kind of like how some torpedoes look. It's a bit hard to describe.

That said it looks pathetic compared to other cannons, but I'm pretty sure it's the correct graphic. Most other regular cannons look quite rectangular to me, not like an improperly loaded texture, just "chunky", that is except for anti-proton shots which look distinctly like tear-drops.
Lieutenant
Join Date: Aug 2012
Posts: 42
# 7
01-10-2013, 08:06 AM
Actually what really got me on to Plasma Cannons was the fact that the visuals looked like a mix between torpedoes and what the Scimitar was firing in ST:Nemesis then when i found out the purple MKXII tact cons were going for 3 mil each I was sold xD

Honestly.. They could revamp the Plasma Cannon visuals so that they shot nothing but those shiny Plasma balls you see on the lower visual settings and I'd be quite happy with that..

I'd leave my FX setting on Low just for that Visual but the plasma balls disappear on me shortly after being fired from my ship. They still connect with what im shooting at I just don't see it visually.
Commander
Join Date: Sep 2012
Posts: 278
# 8
01-10-2013, 11:13 AM
Quote:
Originally Posted by thyuberdude View Post
Actually what really got me on to Plasma Cannons was the fact that the visuals looked like a mix between torpedoes and what the Scimitar was firing in ST:Nemesis
Oh I like the visuals, it's just the salvo looks quite weak and you can hardly the regular single cannon/turret shots, they could just do with being made a bit bigger I think.
Starfleet Veteran
Join Date: Jun 2012
Posts: 34
# 9
02-20-2013, 04:03 PM
I've got this problem too, all graphic settings on high... They start out looking nice & sexy, but if I hit rapid or volley, they turn to ugly flying boxes... No other weapon type does this for me, plasma only.
Commander
Join Date: Sep 2012
Posts: 278
# 10
02-21-2013, 12:35 PM
I recently tried higher graphics settings on STO and I now see the same "boxy" cannon blasts, it's definitely not texture corruption they just look ugly.

The plasma cannons shots actually look much better on the low detail settings as they appear light pale-green torpedoes, which looks awesome. Only problem is they're a bit small looking.

The high detail blasts look awful; most dual heavy cannon blasts do other than anti-proton which seem to be a lot more tear-drop shaped, but the others look horrible. Unfortunately if I turn the graphics back down then I start having things disappear entirely like the Kinetic Cutting Beam, so there seems to be no way to win. I'd kill for an option to force the low-res plasma blasts, or if a high-res version could be created that used the low-res version but added a thin glowing trail.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:03 PM.