Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lieutenant
Join Date: Jun 2012
Posts: 40
# 1 FLeet Support/Photonic Fleet
12-22-2012, 04:33 AM
I'm finally posting something about this. since i started playing and since I've been using science officers. the photonic fleet and even on all characters the fleet support do not work properly and never have. you activate them and they have a 4 in 5 chance of not shooting and disappearing when your in the middle off a massive group of enemy ships....and its been like this since i started playing
Captain
Join Date: Jun 2012
Posts: 1,442
# 2
12-22-2012, 04:53 AM
Both of these abilities require you to be under fire for them to work effectively. They won't work against enemies that aren't shooting you, have stopped shooting you or have been destroyed. These work perfectly fine in PvP where you are usually being shot at most of the time.
Lieutenant
Join Date: Jun 2012
Posts: 40
# 3
12-22-2012, 04:54 AM
wrong ive had them do it in stfs and mirror events while i have group agro by myself. they do not work properly
Republic Veteran
Join Date: Sep 2012
Posts: 87
# 4
12-22-2012, 04:56 AM
I've experienced something similar with Photonic Fleet III however, it may be working as intended. Remember these are relatively weak ships they are not 'real', it is possible they are being 1 shot-ed if you are using them in a mob situation. As an experiment, try deploying when you are on a patrol mission, and down to your last enemy.

The first time we see first see photonic ships is in Voyager Basics, part 1, if I'm not mistaken, and they were more of a distraction to the Khazon, than an actual threat.
Lt. Commander
Join Date: Jun 2012
Posts: 105
# 5
12-22-2012, 04:58 AM
They seem to work fine for me, but I'm an aggressive player who is under fire a lot.
Lieutenant
Join Date: Jun 2012
Posts: 40
# 6
12-22-2012, 05:00 AM
as true as that is my fleet support and my photonic fleet has done this over 6 times today alone siince ive been on. and msot of them were in mirror event and the typ of character i have i get agro alot im sitting there dieing. and under alot of fire./ and they vanished instead of help.
Captain
Join Date: Jun 2012
Posts: 1,442
# 7
12-22-2012, 05:02 AM
Quote:
Originally Posted by vulcanmonk View Post
I've experienced something similar with Photonic Fleet III however, it may be working as intended. Remember these are relatively weak ships they are not 'real', it is possible they are being 1 shot-ed if you are using them in a mob situation.
They do not distribute their shields and have next to no hull, so they probably are dying in massive group. Explosions tend to kill them off regardless as well.
Lieutenant
Join Date: Jun 2012
Posts: 40
# 8
12-22-2012, 05:02 AM
ive seen them be summoned....not take any hits..then vanish....ive seen my FLEET SUPPORT jump in while im surrounded then vanished.....
Captain
Join Date: Jun 2012
Posts: 1,442
# 9
12-22-2012, 05:04 AM
I've seen it happen too, it tends to be within a small time frame when you aren't under attack.
Lieutenant
Join Date: Jun 2012
Posts: 40
# 10
12-22-2012, 05:05 AM
im ussually under fire constantly. so it has nothing to do with that...they just arnt working.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:58 AM.