Ensign
Join Date: Jun 2012
Posts: 15
# 1 help with Omega set
04-01-2013, 02:01 AM
I have Omega X level gear. The armor, shield, and Rifle. But the visuals don't show up. It just shows up as regular armor, not the cool looking armor of Omega.

How do I get the actual Omega visuals to show up?
Lt. Commander
Join Date: Nov 2012
Posts: 136
# 2
04-01-2013, 02:49 AM
I think only XI and XII have the special appearance.

Last edited by mosquito214; 04-01-2013 at 02:51 AM.
Captain
Join Date: Jun 2012
Posts: 1,246
# 3
04-01-2013, 05:46 AM
Can't remember if Omega X has fancy visuals or not; but try the tailor. The STF sets unlock costume options, so if it has any, they'll be there.
Exploration suggestions thread - give it a read

BTW, you'd pronounce it 'Cap'n Manks'

I protest the removal of exploration clusters
Career Officer
Join Date: Jun 2012
Posts: 1,020
# 4
04-01-2013, 06:21 AM
Omega Mk X used to have some basic options (suit/grenade belt/boots) but they removed that with Season 7 - now only Mk XI and XII have costume options.
Please join our peaceful protest to help make STO a better game
Proudly not contributing to PWE's bottom-line since October 2012
Captain
Join Date: Jun 2012
Posts: 3,624
# 5
04-01-2013, 11:52 AM
Enabling armor visuals doesn't do anything?
Ensign
Join Date: Mar 2013
Posts: 19
# 6
04-01-2013, 04:53 PM
Quote:
Originally Posted by reginamala78 View Post
Enabling armor visuals doesn't do anything?
That gives a normal silly armour skin that doesn't look distinct in any way.

t.currently have mkX omega set on
Lt. Commander
Join Date: Jan 2013
Posts: 108
# 7
04-01-2013, 06:08 PM
Even though it shows a picture of a character wearing those items in the reputation menu?

ZOMG, false advertising!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:14 AM.