Captain
Join Date: Jul 2012
Posts: 2,473
# 1 [F Editor] Patrols Vanishing
02-19-2013, 04:45 PM
I'm working on a Foundry mission in which an NPC runs away from an explosion.

I have it set up like this:

Trigger object: Pick up box
{Dialogue}
Marker: Run away from explosion
{Dialogue}
Trigger objects: Complete all

On the map, I have an NPC Attack saur group redressed as the NPC, and patrolling at a fast speed from the explosion site to the marker (a good 20 meters away). Once the player reaches the marker, the NPC must despawn.
Dialogue happens.
Then another Attack Saur group is spawned, again with the same costume. The NPC does some more patrolling, and is set to despawn at a certain time.

The problem is, once the NPC beams in, they instantly fade out, every time. What is going on?

This also causes issues with the NPC-killing-timers I have set up. I can't progress through the mission as intended due to the fact that the NPC never shows up.

Fixes?

stardestroyer001, Admiral, Explorers Fury PvE/PvP Fleet | Retired PvP Player
My Useful List of STO Forum Threads, Ship Builds & More!
It's about time. DEVS NEED ACCOUNTABILITY.
Starfleet Veteran
Join Date: Jun 2012
Posts: 223
# 2
02-19-2013, 06:22 PM
I'm pretty sure this is a known issue, and happens with all kinds of mobs including boffs in the foundry editor. They dont disappear, they just disappear from view and reappear at a random point in the map. Sometimes they come back sometimes they dont. usually occurs as they enter combat.
Captain
Join Date: Jul 2012
Posts: 2,473
# 3
02-19-2013, 06:38 PM
Quote:
Originally Posted by rogueeenterprise View Post
I'm pretty sure this is a known issue, and happens with all kinds of mobs including boffs in the foundry editor. They dont disappear, they just disappear from view and reappear at a random point in the map. Sometimes they come back sometimes they dont. usually occurs as they enter combat.
So what can I do then? My timers don't work if even one NPC hostile vanishes.

Or is it simply a Foundry Editor issue, and the problem disappears once the map is published?

(P.S. Nice profile picture.)

stardestroyer001, Admiral, Explorers Fury PvE/PvP Fleet | Retired PvP Player
My Useful List of STO Forum Threads, Ship Builds & More!
It's about time. DEVS NEED ACCOUNTABILITY.
Commander
Join Date: Jun 2012
Posts: 366
# 4
02-19-2013, 07:15 PM
It's an editor issue.
Cryptic Studios Team
Join Date: Aug 2012
Posts: 1,281
# 5
02-20-2013, 11:33 AM
Yeah, this is a known issue with the editor. Things should work properly once the project is published. The NPCs vanishing like that is due to unpublished maps not having pathing information, which really messes with Patrol performance. The improving of Preview mode is on the list. The usual disclaimers apply.
Captain
Join Date: Jul 2012
Posts: 2,473
# 6
02-20-2013, 01:50 PM
Okay, I'll temporarily publish the mission and see if it works.

stardestroyer001, Admiral, Explorers Fury PvE/PvP Fleet | Retired PvP Player
My Useful List of STO Forum Threads, Ship Builds & More!
It's about time. DEVS NEED ACCOUNTABILITY.
Captain
Join Date: Jul 2012
Posts: 2,473
# 7
02-23-2013, 07:26 AM
No luck. I've published the mission, and the timer still refuses to go off due to the NPCs vanishing.

EDIT: Upon further inspection, it appears as if the patrol begins movement if the Player is within a certain distance. So if I have the patrol where it is now (900m away from Player), the patrol will never start.

stardestroyer001, Admiral, Explorers Fury PvE/PvP Fleet | Retired PvP Player
My Useful List of STO Forum Threads, Ship Builds & More!
It's about time. DEVS NEED ACCOUNTABILITY.

Last edited by stardestroyer001; 02-23-2013 at 08:21 AM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:32 PM.