Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Windows 7 and Nvidia Drivers
01-12-2010, 07:19 AM
Hey Guys,

I know this is most likely a lost cause but I thought that it was at least worth a try. I have a Sony Vaio VGN-AR790U that I just recently upgraded to Windows 7 64-bit. Unfortunately, it seems that after the upgrade my Nvidia GeForce 8600M graphics card is no longer recognized by the system. I've tried practically all the drivers on the Nvidia webpage and none have worked. I have also contacted Sony Support and all they can do is give me the Vista drivers because they have not bothered to make any Windows 7 drivers for their systems. Sadly, the Windows Vista driver when ran states that it can only be applied to the Windows Vista OS.

So, I am looking for ideas if anyone has any. Any help would be appreciated.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-12-2010, 07:33 AM
I think it's a Windows 7 thing, as I have had the same trouble when I upgraded my PC to a Nvidia 8800 card. It worked fine at first, then out of the blue it was no longer reconized. After re-installing the drivers to no avail I, just removed the card itself then re-installed it, and everything now runs great, and has been for a few months now. Why that happened is beyond me, but I hope that helps a little. Also, you may have allready, but Nvidia's site has a list of all the drivers, just type in your info when you get to the driver download section, and there should be a driver for your card thats made for 7- 64 bit. Thats how I got mine, and it was somewhat of a generic driver to boot. It covered from 8600 to 8800's I beleive.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-12-2010, 07:35 AM
try http://www.guru3d.com for drivers. They are modified to fit a range of cards, including mobile ones. Also emember, that the latest drivers may not work for STO due to an ongoing driver issue which nvidia are rectifying.

The safest drivers to use are the 190.** series drivers. You might be able to use the latest nvidia drivers, as a work around is running the game in windowed mode in a smaller resolution than your desktop. Although with this, i very much doubt your laptop and graphics card would be able to handle this.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-12-2010, 07:45 AM
I think mobile drivers are still very picky and you need to download them from the manufacturer directly, which in turn means they're not as up to date as downloading from nvidia/ati/etc.

At least this was how it used to be when i used my old Radeon M9.. Omega drivers were quite the saviour back then
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-12-2010, 07:52 AM
Quote:
Originally Posted by Sealance View Post
I think mobile drivers are still very picky and you need to download them from the manufacturer directly, which in turn means they're not as up to date as downloading from nvidia/ati/etc.

At least this was how it used to be when i used my old Radeon M9.. Omega drivers were quite the saviour back then
Like Sealance said your going to have to wait for Sony to develop a workaround/new drivers. Someone else posted a link that might help you. Good Luck!!!!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-12-2010, 07:57 AM
Try this one: http://www.laptopvideo2go.com/driver....81/disclaimer

Download both, the driver and the .inf file. Put it both in the same directory & install from there.

...engage!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-12-2010, 08:00 AM
Thanks for the replies guys. Although nothing has worked I do appreciate the help. I guess I will just have to take the time to revert my system back to Windows Vista and backup all my files or settle for trying to play the Open Beta on my gf's system.

Thanks again for your help. Greatly appreciated.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-12-2010, 08:02 AM
What ends up happening on some of these PCs is that first you have to install a PCIE/AGP/YourSlot driver, inorder for the card itself to be recognised. Try looking for a board update, or something along those lines. If I didnt have to head to work I would help.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-12-2010, 08:04 AM
Quote:
Originally Posted by Eldradt
Try this one: http://www.laptopvideo2go.com/driver....81/disclaimer

Download both, the driver and the .inf file. Put it both in the same directory & install from there.

...engage!
Works 100 % on the very same notebook with win 7 x64. You realy tryed? :-(
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-12-2010, 08:16 AM
Quote:
Originally Posted by Eldradt
Works 100 % on the very same notebook with win 7 x64. You realy tryed? :-(
I honestly have to say that I did not try this one. But, that is simply because I work as a computer techie and I saw the disclaimer that states that you try this at your own risk which made me feel uncomfortable about it. But, I guess I can make a restore point and give it a try anyways.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:24 AM.