Go Back   Star Trek Online > Feedback > Federation Gameplay
Login

Reply
 
Thread Tools Display Modes
Lieutenant
Join Date: Jun 2012
Posts: 87
I had a funny experience tonight. I was in the Alpha Centauri sector and tried to transwarp to Eta Eridani in my fleet advanced heavy cruiser/excelsior. The ship did the regular warp tunnel thing and the ship computer did the "transwarp in 3..2..1..". But instead of warping in to space like normal. It did a clunk sound, sparkling lights appeared on the nacelles and then a powering down sound happened last. I clicked on the transwarp button again and everything was in cool down mode. I wish I had a video of it. It reminded me of scene from Star Trek III: The Search for Spock when Captain Styles of the U.S.S. Excelsior tried to go after the Enterprise.
Survivor of Romulus
Join Date: Jun 2012
Posts: 1,691
# 2
05-19-2013, 08:23 PM
yeah i had it happen last week in my tuffli...and about 2 months ago in my atrox ahahha

Quote:
Originally Posted by borticuscryptic View Post
I find this line of replies sadly hilarious. We put a lot of work into the massive list of fixes/changes above, and ya'll are hung up on the ability to skip our content. =p
Captain
Join Date: Jun 2012
Posts: 1,500
# 3
05-19-2013, 08:26 PM
Yep, it's an easter egg reference to the movie you mentioned. Although I thought that only the Excelsior had it.
Take it easy!

Ishmael@scurry5: A Nibbling Sci
"Squeak?"
Survivor of Romulus
Join Date: Jun 2012
Posts: 1,691
# 4
05-19-2013, 08:32 PM
Quote:
Originally Posted by scurry5 View Post
Yep, it's an easter egg reference to the movie you mentioned. Although I thought that only the Excelsior had it.
probably is and there were map change bugs those times i tried to use it lol...but i got the CD for them

Quote:
Originally Posted by borticuscryptic View Post
I find this line of replies sadly hilarious. We put a lot of work into the massive list of fixes/changes above, and ya'll are hung up on the ability to skip our content. =p
Captain
Join Date: Dec 2012
Posts: 844
# 5
05-19-2013, 08:49 PM
since i usually fly the advanced retrofit excelsior when this happens i usually wind up getting a laugh.
Just brings back memories of scotty when he sabotaged the excelsior lol
Captain
Join Date: Jun 2012
Posts: 1,353
# 6
05-19-2013, 08:55 PM
Yeah, it's the easter egg. If you look at the description of the excelsior retro (And fleet) it mentions that there's a chance of the advanced transwarp drive failing.
Starfleet Veteran
Join Date: Nov 2012
Posts: 298
# 7
05-20-2013, 05:26 AM
I had it happen to me once, just once so far, when I was commanding my C-store Excelsior, a good while back. Waiting for it to happen on any of my other ships, though my Fleet Excelsior is the most likely to have it happen.

Damn you Scotty! Stop drinking the green stuff already while I Transwarp!
Career Officer
Join Date: Jun 2012
Posts: 2,942
# 8
05-20-2013, 05:30 AM
Wish the other ships didn't hear it clunk out.

Embarrassing.

But dead funny when it happens to someone else. =3

LTS Join Date : September 2010. Boldly going forward because Cryptic forgot reverse.
I am currenty unsupervised, anyone who knows me will inform you that this will likely lead to trouble.=3
As I grind through the valley of XP, I shall fear no nerf.
Lt. Commander
Join Date: Feb 2013
Posts: 179
# 9
05-20-2013, 07:41 AM
Flew my Excelsior Retrofit for eons before it's Transwarp Drive failed. Glad it's so very infrequent otherwise it would be more annoying.
Survivor of Romulus
Join Date: Sep 2012
Posts: 5,872
# 10
05-20-2013, 07:58 AM
Quote:
Originally Posted by jkwrangler2010 View Post
I had a funny experience tonight. I was in the Alpha Centauri sector and tried to transwarp to Eta Eridani in my fleet advanced heavy cruiser/excelsior. The ship did the regular warp tunnel thing and the ship computer did the "transwarp in 3..2..1..". But instead of warping in to space like normal. It did a clunk sound, sparkling lights appeared on the nacelles and then a powering down sound happened last. I clicked on the transwarp button again and everything was in cool down mode. I wish I had a video of it. It reminded me of scene from Star Trek III: The Search for Spock when Captain Styles of the U.S.S. Excelsior tried to go after the Enterprise.
Yeah, it's on purpose but happens on very rare ocassions. It's a nice little homage by Cryptic to the movie. When it happens, it never fails to bring up a smile on my face.
Looking for a genuine Star Trek experience?

Join the Klingon Empire. Glory awaits!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:52 AM.