Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Starfleet Veteran
Join Date: Jul 2012
Posts: 561
Hello all. ^^ I have been using the Heavy phaser beam satellite turrets on my Intrepid class and I have noticed that they dont shoot at bad guys all the time. Most of the time you drop them and they just sit there doing nothing. Please fix this bug...
Lieutenant
Join Date: Jun 2012
Posts: 47
# 2
03-22-2013, 11:32 AM
Just spotted your post. Thanks for bringing this issue forward...

Well then, same here...sometimes they shoot, sometimes they aren't firing at all. I have experienced that mostly with torp platforms being a dud so to say. Usually they should fire on any foe within 10km....or am I wrong? Stowiki says 'nearby hostiles', which leads to speculations on range as it isn't clearly defined...

Sometime I've placed them within 2km of a gate/cube - no shots. Next time I've dropped them 5km distance to Donatra and they deliver torp/beam shots. Due to that that lack of reliability, I've pretty much stopped using them. Since the damage inflicted is not big anyway according to Stowiki:

...'For a level 51 Satellite compared with an enemy ship, same rank or same turret, the damage is very small ( each hit on target will deal 10 HP damage with a critical chance for 22 HP) but can be a good help when you need to destroy a strong ship (for example a I.R.W ship or a Daedrix battleship), even in Elite Mode gameplay.'...

Source: http://www.stowiki.org/Deployable_De...pedo_Platforms

So a shield/weapons/auxiliary battery might be the better choice for the device slot anyway instead...
Starfleet Veteran
Join Date: Jul 2012
Posts: 561
# 3
03-22-2013, 12:24 PM
Yeah, I just thought it could be another target to take fire off me to lol. But they should still work. Hope they fix it. :S
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:57 PM.