Ensign
Join Date: Aug 2012
Posts: 5
# 1 Version mismatch...
04-11-2013, 04:57 PM
I'm a bit confused here...

I downloaded STO Legacy of Romulus (ver. ST.25.20121026a.8) then installed that, but still got an elder version number (ver. ST.24... something) on the holodeck.

Is that supposed to work this way?
Ensign
Join Date: May 2013
Posts: 12
# 2 Version Mismatch seconded.
05-04-2013, 03:25 PM
I am experiencing Version Mismatch error when attempting to log into the game.
However my version number is : ST.25.20130324a.20.
Running Win7-64
Career Officer
Join Date: Jul 2012
Posts: 18
# 3
05-05-2013, 11:48 AM
i have too a version mismatch latly this game is getinng worse
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:13 PM.