Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Career Officer
Join Date: Oct 2012
Posts: 114
# 411
10-27-2013, 09:59 AM
Klingon honour guard is still not fixed tried it out a few days ago. So you can go back to spammin its not fixed. Same for the missing leg pieces for Omega on my Republic Romulan toon. Still bugged.
Starfleet Veteran
Join Date: Sep 2012
Posts: 999
# 412
10-27-2013, 11:02 PM
This thread has almost made it to page 2. Unacceptable. Its been 199 days since Bort started this thread btw.
Ensign
Join Date: Jul 2012
Posts: 1
# 413
10-29-2013, 05:59 PM
I'd been away awhile, came back, blitzed the reps, got the Mk12 gear, got the accolade, completed the costume unlock projects

and nothing.

Every time I go to the tailor and check under every dropdown for head and uniform I see no Omega gear at all. Super buzzkill.
Career Officer
Join Date: Jul 2012
Posts: 1,342
# 414
10-29-2013, 07:53 PM
Quote:
Originally Posted by pwstolemyname View Post
This thread has almost made it to page 2. Unacceptable. Its been 199 days since Bort started this thread btw.
Kinda glad Bort was a player at one time and knows how we feel.. oh wait.. haven't heard him come back to this thread in ages.. hmm how times change.

Yep kdf adapted visuals for me anyways, I have the rest of the armor visuals just no helmet.. been like that for ages now.
Like my Fan Page Here
xXLocutusXx
Rihannsu
Join Date: Jun 2012
Posts: 1,792
# 415
10-29-2013, 08:40 PM
Quote:
Originally Posted by xlocutusofborgx View Post
Kinda glad Bort was a player at one time and knows how we feel.. oh wait.. haven't heard him come back to this thread in ages.. hmm how times change...
Personally, I don't count ~3wks as "ages", but perhaps you missed this:

http://sto-forum.perfectworld.com/sh...&postcount=370


You can find/contact me in game as @PatricianVetinari. Original Join Date: Feb 2010.
Need Help with Ship's Power? Check out my Ship Power Guide and Calculator.
Career Officer
Join Date: Jun 2012
Posts: 149
# 416
10-30-2013, 08:59 AM
I gave it a thought... It is possible it is not working properly on tribble because the rep is not transferred correctly from holo (omega doesn't show as completed). Well, anyways we need to wait.
Captain
Join Date: Oct 2012
Posts: 10,007
# 417
11-01-2013, 02:00 PM
Still waiting for news.
http://fc08.deviantart.net/fs70/f/2014/144/0/2/sto_sig_character_by_rattler20200-d7jlk1h.png
Quote:
Originally Posted by Ruby Rose
And then I sneezed. And then I exploded.
Starfleet Veteran
Join Date: Sep 2012
Posts: 999
# 418
11-02-2013, 12:02 PM
This thread is getting dangerously close to the bottom of the page again....
Rihannsu
Join Date: Feb 2013
Posts: 203
# 419
11-03-2013, 01:19 AM
Recently my Omega outfit unlock finally worked properly for the first time ever, the left wrist option that was always missing had finally appeared.

Unfortunately, this was very, very shortlived.

Since last patch I can no longer wear it AT ALL! When I try to switch outfit nothing happens. If i try to rename this outfit I get an error that it uses invalid parts. If i modify it all slots and all parts are there, with upper, lower and feet greyed out. I can change things and load and save the outfit but NOT purchase it, getting that same error again: invalid parts.
Captain
Join Date: Oct 2012
Posts: 10,007
# 420
11-03-2013, 10:06 AM
Really? It finished?
http://fc08.deviantart.net/fs70/f/2014/144/0/2/sto_sig_character_by_rattler20200-d7jlk1h.png
Quote:
Originally Posted by Ruby Rose
And then I sneezed. And then I exploded.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:14 AM.