Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
Don't know if it is already known...

I had this happening in the laggy periods of the game e.g. you know around the time Loading takes ages and you always appear as ship on ground and char in space, have enough Starfleet Merits to do the Promotion all the way through and start hitting "Promote"...

It doesn't register immediately and I hit it like 3-5 times in the hopes that it works and the Bridge Officer came out as "Commander" and also has all the Skills unlocked.

They even use their Ground skills (like Stealth on lvl4 for Tactical) etc. but the Space part Skills do not appear in the "Skills Selection" (P) or the GUI (only a 2nd skill slot for the Officer first promoted)



I got a feeling that a lot of "functions" can malfunction or do not work the intended way whenever the servers lag a lot. I even lost a dozen of Skillpoints 1000+ because of it cause I spent em but it didn't register in time and also didn't refund the points.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-18-2010, 09:08 AM
Same thing happened to me, when the game was very laggy.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:05 PM.