Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
One of the missions you get while exploring Delta Volanis Cluster asks you to deliver 10 Shield Generators. The trouble is that the Shield Generators are only sold at the Commodities Broker on Earth Spacedock, but leaving the system to buy them seems to make the quest bug out so that you can't complete it. When you return with the generators and approach the planet, you are hailed and you can click through the dialogue until you get to "Deliver Supplies," but when you select this option, nothing happens.

Tonight, after being unable to complete the mission, I dropped it and left the system in search of a different mission to finish out the "Explore Delta Volanis Cluster" mission from Lt. Grall. The next system I entered gave me the exact same mission, but this time I was able to complete it since I already had the items in inventory.

You should probably put Shield Generators on the ship Replicators (oh noes the Replicators!) as a workaround to this bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-16-2010, 07:30 PM
I had this same problem too, only my quests asked for Medical Supplies. I left the system when "Deliver Supplies" failed and got the same quest in the next one. That one didn't work either. I completely dropped them BOTH, logged out (because the next system I went to did not finish loading), then when I got back on I went to another system and did a completely different mission for my third explored system.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-29-2010, 09:38 PM
Quote:
Originally Posted by proudnerd View Post
I had this same problem too, only my quests asked for Medical Supplies. I left the system when "Deliver Supplies" failed and got the same quest in the next one. That one didn't work either. I completely dropped them BOTH, logged out (because the next system I went to did not finish loading), then when I got back on I went to another system and did a completely different mission for my third explored system.
Same problem. Same resolution. Thanks!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-29-2010, 10:07 PM
I had to deliver medical supplies, but as soon as they were delivered, all contact with the planet stopped. I was unable to complete the mission.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-30-2010, 12:18 AM
They did fix this in the last few days of open beta but I guess not in the final. I have completed Kinjer patrol twice with no credit for completion.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-31-2010, 03:41 AM
Same thing with communications arrays. You can deliver, but not hail the planet again.

Make sure you are at least lvl4 before trying to complete Kinjer, that caught me out too.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-01-2010, 01:38 AM
I'm there too now. I had delivered 1 rations. But i have to give 10. When I get to the cluster I can always resume the mission but there's no way to contact the planet or to produce a way to give more if I have them in my inventory. I tried dragging it to the planet but ofcourse that doesn't work also because it would be discarded if you do.

(this is with the latest headstart patch).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-02-2010, 05:48 AM
not working for me too right now
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-02-2010, 05:57 AM
This bug was present during the open beta, and here is a work around.
  1. Start the mission, discover what consumable the planet needs
  2. Leave the system, fly to Earth Spacedock and purchase the consumables
  3. Fly back to Delta Volanus Cluster, and you should eventually get a message similar to "Continue: Resupply System X", click it
  4. As soon as you enter the system and before you head to the planet, open your journal and drop the quest
  5. Fly to the planet. You will receive a hail asking for the ten consumables they wanted previously
  6. You can now deliver the consumables

Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
02-02-2010, 06:00 AM
Same here with Delta Volanis - I had the mission to deliver 10 shield generators, dropped off the 4 I had and didn't think about it again. Returned to the system the next day, and I can't even hail the planet. I used the "Continue mission" popup to warp straight there from sector space, and the system is silent. No welcome message, and flying into the planet only results in a blinding bloom shine from the atmosphere I tried to hail manually, and only see the expected commanders/admiral on the list.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:46 PM.