Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 New Nvidia drivers released
01-19-2010, 05:24 AM
Hi All

Nvidia just released some new WHQL drivers. They are version 196.21.
Download http://www.nvidia.com/Download/index.aspx?lang=en-us
Release Notes: http://us.download.nvidia.com/Window...ease_Notes.pdf

I haven't tested them yet, but I hope they improve things a bit.

-
pato
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-19-2010, 05:48 AM
I saw in the release notes that they claim to have resolved the hitching in Champions!!! Downloading now. Will report back later.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-19-2010, 06:33 AM
Smooth as butter in both games. It's been fixed and it was Nvidia's fault. Hahahahaha! Gonna be lots of relieved people at Cryptic.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-19-2010, 06:48 AM
Quote:
Originally Posted by smackphat View Post
Smooth as butter in both games. It's been fixed and it was Nvidia's fault. Hahahahaha! Gonna be lots of relieved people at Cryptic.
now they just need to sort out the ATI anti-aliasing problem!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-19-2010, 07:16 AM
Quote:
Originally Posted by Intrepidox View Post
now they just need to sort out the ATI anti-aliasing problem!
indeed
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-19-2010, 07:59 AM
Quote:
Originally Posted by smackphat View Post
Smooth as butter in both games. It's been fixed and it was Nvidia's fault. Hahahahaha! Gonna be lots of relieved people at Cryptic.

i'v been reading release notes it doesnt say anything about STO
do u think its fixed the black screen issue and the overheating ? i dont , but im still gona check this out ..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-19-2010, 08:28 AM
tried to delete..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-19-2010, 08:30 AM
Quote:
Originally Posted by smackphat View Post
Smooth as butter in both games. It's been fixed and it was Nvidia's fault. Hahahahaha! Gonna be lots of relieved people at Cryptic.
I afraid there wont be relieved people at the cryptic , i just installed the new drivers only took me 5 mins
to figure out on the mining colony mission , my Video Card got overheated again and i got a Black Screen with the music on the back ground as usuall , Overheating//Black screen issue HAS NOT BEEN RESOLVED
the problem remain , waiting for any further news..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-19-2010, 09:00 AM
Quote:
Originally Posted by repsycho View Post
I afraid there wont be relieved people at the cryptic , i just installed the new drivers only took me 5 mins
to figure out on the mining colony mission , my Video Card got overheated again and i got a Black Screen with the music on the back ground as usuall , Overheating//Black screen issue HAS NOT BEEN RESOLVED
the problem remain , waiting for any further news..
That sounds like a hardware issue. Most recent video cards are hardwired to throttle when it reaches a certain temperature.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-19-2010, 09:25 AM
Im playing games (with DX10 using gamer XPS-7 computer) with much harder engines wich require much more powerfull computers than STO needs and they all are working perfectly with highest possible settings , And also i already tried every possible step to resolve it. Getting kinda tired from all these smart fellas who think they knew everything.
Bottom line its not a hardware issue.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:04 PM.