Ensign
Join Date: May 2013
Posts: 5
So I finally got a email from support with a automated response problem is when I email them it tells me that my email isnt associated with the incident. So I went to account to try and figure out whats wrong. Apparently when I log in and go to account it changes my freaking account, right now when I clicked on account it says Welcome Sanderlohmus which is not my account clicked change email now it says Welcome Hidanrage2. Redeem beta keys Welcome Danieljunior555. What the hell is going on. This is unacceptable the tech support took greater than 2 weeks to respond with a automated response then when more issues come up over the same problem which was never resolved they are no where to be found. I understand they are busy but as someone who has spent money on the game I feel I should be able to get issues like this resolved. I still have my cryptic and PW account link problems and characters missing.
Career Officer
Join Date: Jun 2012
Posts: 2,196
# 2
06-11-2013, 06:12 PM
In case you haven't noticed, the description to this Forum is...
Quote:
Receive peer to peer support for technical issues in regards to Star Trek Online here!
... and no Peer will be able to help you with an Account issue. You need to post this thread in the PWE Tech Support Forum... http://techsupport.perfectworld.com/
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:11 PM.