Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
On two separate occasions last night I did not receive a quest reward item upon completing a mission. One was one of the Gateway missions and the other was one of the free bridge officers. I think another bridge officer one failed yesterday as well. As it is beta I do not mind but this is a really big problem come release and will generate a ton of GM tickets if not addressed before launch. Probably a server load issue?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-22-2010, 07:14 AM
I also did not receive a bridge officer after completing a mission. In my case, I forgot to select an officer the first time, cancelled, and then rehailed the admiral to complete the mission. The issue could be related to cancelling or to forgetting to choose a reward the first time.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-22-2010, 07:44 AM
I'm seeing this same issue. I have encountered it before and after the patch. All of my missing rewards seem to be blue ship items. In the four times it has happened, I haven't found anything that I am doing different than any other mission.

I do get the usual mission rewards, points and merits, but no item reward.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-23-2010, 10:05 AM
Actually, I was wrong. I did receive my bridge officer, I just didn't know it. I had to "commission" the bridge officer in the Assignments tab of the player/ship setup window. That wasn't obvious to me at all, and I didn't see any mention of it in the game.

If I recall, my first bridge officer was automatically added to my ship, so I didn't know there was an extra step.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-31-2010, 03:01 PM
the ultimate Klingon quest missing reward
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-31-2010, 03:02 PM
I lost another quest reward. This time (I've lost 2 BOs so far, already) it was the Phaser Turret Kit that I've been waiting ages for. It's getting a little ridiculous, now...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-31-2010, 04:38 PM
I've completed two "Bridge Officer Requisition" missions since the head start began, and have yet to receive either officer in my inventory.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-31-2010, 04:45 PM
Quote:
Originally Posted by TemporalParadox View Post
I've completed two "Bridge Officer Requisition" missions since the head start began, and have yet to receive either officer in my inventory.
Just so you know they don't show up in your inventory they show under the assignments tab when you hit "U" and you have to commission them, but even then you might not of received one cause it is indeed bugged and some ppl are not getting the Boff's like me
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-31-2010, 06:35 PM
Quote:
Originally Posted by daveywavey View Post
I lost another quest reward. This time (I've lost 2 BOs so far, already) it was the Phaser Turret Kit that I've been waiting ages for. It's getting a little ridiculous, now...
I, too, had a kit not given to me just last night...was the kit reward for one of the Patrol missions. Was interested in finding out if was worth swapping out my mines for too.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:11 PM.