Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1221
12-10-2010, 07:45 AM
Hi I've just installed everything and followed all steps accordingly. Everything seems to be working fine, except whenever I am in the launcher and it is patching up; everytime a substantial part of the patch have been downloaded the application just quits by itself. Normally after 30%, it happened at 47% and 50%. Ofcourse everytime it does so, the already downloaded patch is still reccorded. Just want to know why this happens
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1222
12-10-2010, 09:49 AM
Quote:
Originally Posted by ZachRobbie
Hi I've just installed everything and followed all steps accordingly. Everything seems to be working fine, except whenever I am in the launcher and it is patching up; everytime a substantial part of the patch have been downloaded the application just quits by itself. Normally after 30%, it happened at 47% and 50%. Ofcourse everytime it does so, the already downloaded patch is still reccorded. Just want to know why this happens
its starting doing that recently for me too... I haven't narrowed down as to why. Just starting it over at least works for now until patching is done.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1223
12-10-2010, 09:52 AM
Quote:
Originally Posted by mdhus View Post
I've tried it with the GLSL enabled and disabled.... and have had the most success with it disabled. I log in, and have to click "Yes, with lowered settings" (otherwise it will crash immediately). Then, it runs through the "Cryptic" and "Atari" loading screens. After that, it gets to the screen that wants me to adjust the sliding bar until I can see all three lines. Every time I get to this point, I get the "Oops Cryptic Error", and it closes without going any further.
leave GLSL on

Open the wrapper up (show package contents) and run Wineskin.app. In there go to advanced, and do a Test Run (debug Mode) and try the game out.

After it crashes and shuts down, you should be offered to see the Logs.

Copy and paste the lastwine log onto a site like pastebin.com then put the link here so I can look at it.. see if anything jumps out as to why its crashing.

The Oops error you can get later with GLSL off is usually caused by GLSL being off when it needs to be on.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1224
12-10-2010, 10:51 AM
I'm having trouble, during gameplay the application switches to FIrefox or something for a few seconds, I can either click STO in the dock or wait a little to bring it back but as it is now the game is unplayable.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1225
12-10-2010, 11:23 PM
Quote:
leave GLSL on

Open the wrapper up (show package contents) and run Wineskin.app. In there go to advanced, and do a Test Run (debug Mode) and try the game out.

After it crashes and shuts down, you should be offered to see the Logs.

Copy and paste the lastwine log onto a site like pastebin.com then put the link here so I can look at it.. see if anything jumps out as to why its crashing.

The Oops error you can get later with GLSL off is usually caused by GLSL being off when it needs to be on.
I attached the log as a txt file to this post...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1226 Full File Check??
12-11-2010, 04:10 AM
Hi Doh123, thanks for all the support and making this game run on macs. I've played around with my broken install but i ve never seen and option to do a full file check.
How do you do that?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1227
12-11-2010, 07:49 AM
Quote:
Originally Posted by DekuScrubby View Post
I'm having trouble, during gameplay the application switches to FIrefox or something for a few seconds, I can either click STO in the dock or wait a little to bring it back but as it is now the game is unplayable.
This is a Mac OS X focus problem. There is a workaround/fix for the issue, and its in fully capturing the display so nothing else can use it. Right now XQuartz fullscreen mode does not support this, but it is being worked on. You can limit how often this happens by closing programs... the more you have running, the more often it has a chance of happening. For me it only happens maybe once an hour for a few seconds at most, and sometimes I got 1.5 hours without seeing it. While the issue is being addressed, I wouldn't count on a fix anytime this month.


Quote:
Originally Posted by mdhus View Post
I attached the log as a txt file to this post...
Nothing jumps out at me except it seems to be crashing while doing normal mshtml stuff... I think. Is this the log of it crashing while still in the launcher/patcher? or maybe slightly after you hit Engage? You might try doing a full file check in STO just to see if anything is corrupted. I have had issues before when trying to update wrappers of them crashing constantly in the login/patcher area, and never really figured out what caused it... just always took a fresh clean wrapper and it worked fine. I need to know more about what leads up to this error and when it happens exactly.

Quote:
Originally Posted by havam
Hi Doh123, thanks for all the support and making this game run on macs. I've played around with my broken install but i ve never seen and option to do a full file check.
How do you do that?
On the patcher window there is a link at the top that says "options" where you can force a file check. It often (but not always) finds problems.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1228
12-11-2010, 09:42 AM
...........I have a Intel GMA X3100. running 10.6.5..........fml. I'm never going to play this game.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1229
12-13-2010, 06:27 PM
Doh: I noticed in the latest revision of WINE they are adding support for ActiveX controls for the built in browser. Since the updater is basically a browser window with an ActiveX component to take care of the update/check/etc does this mean we can soon expect the ie components being removed from the wrappers and container?

Also I was wondering if we can expect a Beta 3 anytime soon? I noticed that there has been some more progress upstream on multi-display support and improvements on some more complex shaders (still dreaming of the day I can run it maxed out like I can under windows). I would build myself a wrapper against the latest build, but there really aren't any instructions on how to combine all of the various components you have brought together for making it work so well so far.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1230
12-13-2010, 07:36 PM
Quote:
Originally Posted by Athirne View Post
Also I was wondering if we can expect a Beta 3 anytime soon? I noticed that there has been some more progress upstream on multi-display support and improvements on some more complex shaders (still dreaming of the day I can run it maxed out like I can under windows). I would build myself a wrapper against the latest build, but there really aren't any instructions on how to combine all of the various components you have brought together for making it work so well so far.
there isn't enough improvements to really warrant it in playing the actual game I have one running right now using everything from the latest Wineskin Beta and Wine 1.3.9, but its really no different in performance. The multi-monitor fix in Xquartz is about a specific bug, it doesn't add any display capturing or allowing normal single screen resolutions for multi-monitor set ups.

and for ActiveX... there is more to the login patcher than that, and there is more to how its currently working than IE :-P take WIne and install IE7 and get the patcher to work, it wont work the same, and have render issues and sometimes little script errors. How did I get it to work as good as it does.... well it was fun!
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:14 AM.