Ensign
Join Date: Jul 2012
Posts: 19
# 2131
07-27-2012, 10:48 AM
Quote:
Originally Posted by therealdoh123 View Post
works the same as Lion
Fantastic. Thanks :-)
Ensign
Join Date: Jul 2012
Posts: 1
# 2132
07-27-2012, 11:40 AM
Quote:
Originally Posted by therealdoh123 View Post
works the same as Lion
Are you sure about that? I just reinstalled it and wineskin gave me an error about X11, and it wouldn't install.

The reason I was trying to reinstall it is because previously when playing it was only using part of my screen in fullscreen, leaving the desktop showing below.
Career Officer
Join Date: Jun 2012
Posts: 177
# 2133
07-27-2012, 11:53 AM
Quote:
Originally Posted by emhofgallifrey View Post
Are you sure about that? I just reinstalled it and wineskin gave me an error about X11, and it wouldn't install.

The reason I was trying to reinstall it is because previously when playing it was only using part of my screen in fullscreen, leaving the desktop showing below.
what kind of error? Its working fine for me.
Ensign
Join Date: Jul 2012
Posts: 5
# 2134
07-27-2012, 11:30 PM
I get the same error about X11. Here's the wineskin test log:

WineskinX11: main(): argc=8
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=8
Attempting to use pixel depth of 24
[3423093.452] WineskinX11 starting:
[3423093.452] X.Org X Server 1.12.99.0
[3423093.452] Build Date: 20120410
[3423093.452] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
[3423093.471] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/misc/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/TTF/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/OTF/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/Type1/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/100dpi/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/75dpi/, removing from list!
[3423093.472] [dix] Could not init font path element /Library/Fonts, removing from list!
[3423093.472] [dix] Could not init font path element /System/Library/Fonts, removing from list!
[3423093.501] (EE) Error compiling keymap (server-2930)
[3423093.501] (EE) XKB: Couldn't compile keymap
[3423093.514] (EE) Error compiling keymap (server-2930)
[3423093.514] (EE) XKB: Couldn't compile keymap
[3423093.514] XKB: Failed to compile keymap
[3423093.514] Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.
[3423093.514]
Fatal server error:
[3423093.514] Failed to activate core devices.


Using latest Macbook Air 11-inch (mid-2012) with Mountain Lion. Used to work great on Lion.

This was a test from Wineskin itself, not STO in wineskin. So wineskin itself has a problem or a dependency it uses has a problem.

Last edited by spacediver; 07-27-2012 at 11:35 PM.
Ensign
Join Date: Jul 2012
Posts: 5
# 2135
07-28-2012, 09:54 AM
figured it out. You need to install the X11 Server for Mountain Lion which you can get here: http://xquartz.macosforge.org/trac/wiki. Version 2.7.2 is the latest supported version for ML that you want. The upgrade to ML removes X11. After installing it, log out and log back in and try STO now.

You might also need gcc 4.2, but try without first. You can install gcc by installing Homebrew (brew) here: http://mxcl.github.com/homebrew/, GCC Installer (https://github.com/kennethreitz/osx-gcc-installer/) or installing XCode's Command Line Tools. If you had brew running before the ML upgrade, do a brew update. Running 'brew doctor' will let you know if you're missing anything.

If you haven't figured it out yet, you also need to go to System Preferences - Security & Privacy, and set "Allow applications downloaded from Anywhere" (you'll need to click the lock to do that).

Last edited by spacediver; 07-28-2012 at 10:18 AM.
Career Officer
Join Date: Jun 2012
Posts: 177
# 2136
07-28-2012, 11:44 AM
Quote:
Originally Posted by spacediver View Post
I get the same error about X11. Here's the wineskin test log:

WineskinX11: main(): argc=8
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=8
Attempting to use pixel depth of 24
[3423093.452] WineskinX11 starting:
[3423093.452] X.Org X Server 1.12.99.0
[3423093.452] Build Date: 20120410
[3423093.452] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
[3423093.471] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/misc/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/TTF/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/OTF/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/Type1/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/100dpi/, removing from list!
[3423093.472] [dix] Could not init font path element /tmp/Wineskin/share/fonts/75dpi/, removing from list!
[3423093.472] [dix] Could not init font path element /Library/Fonts, removing from list!
[3423093.472] [dix] Could not init font path element /System/Library/Fonts, removing from list!
[3423093.501] (EE) Error compiling keymap (server-2930)
[3423093.501] (EE) XKB: Couldn't compile keymap
[3423093.514] (EE) Error compiling keymap (server-2930)
[3423093.514] (EE) XKB: Couldn't compile keymap
[3423093.514] XKB: Failed to compile keymap
[3423093.514] Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.
[3423093.514]
Fatal server error:
[3423093.514] Failed to activate core devices.


Using latest Macbook Air 11-inch (mid-2012) with Mountain Lion. Used to work great on Lion.

This was a test from Wineskin itself, not STO in wineskin. So wineskin itself has a problem or a dependency it uses has a problem.
This is usually a permissions issue with the wrapper itself or just /tmp on your machine. Being that you said its a 2012 and mountain lion, I'd assume its the wrapper. Migration Assistant sometimes tears up wrappers. The first thing i'd do in that case is download a new copy of the wrapper and move the game folder from the old one into the new one and see what happens.



Quote:
Originally Posted by spacediver View Post
figured it out. You need to install the X11 Server for Mountain Lion which you can get here: http://xquartz.macosforge.org/trac/wiki. Version 2.7.2 is the latest supported version for ML that you want. The upgrade to ML removes X11. After installing it, log out and log back in and try STO now.
that can help, but its not actually needed... it is possible if there was an issue on your machine (especially with /tmp), going through that process fixed it though.

Quote:
Originally Posted by spacediver View Post
You might also need gcc 4.2, but try without first. You can install gcc by installing Homebrew (brew) here: http://mxcl.github.com/homebrew/, GCC Installer (https://github.com/kennethreitz/osx-gcc-installer/) or installing XCode's Command Line Tools. If you had brew running before the ML upgrade, do a brew update. Running 'brew doctor' will let you know if you're missing anything.
you do NOT need gcc or Xcode to run the game... period. You do need them if your wanting to build custom engines in Wineskin Winery, but thats only if your wanting to make your own wrappers or modify this one a ton. If you do an engine build in Winery with W2.5.5EngineBase or later, it'll install gcc 4.2 for you anyways if you want and you don't need to download it it anywhere else.

Quote:
Originally Posted by spacediver View Post
If you haven't figured it out yet, you also need to go to System Preferences - Security & Privacy, and set "Allow applications downloaded from Anywhere" (you'll need to click the lock to do that).
you do not have to do that... you can run any app that Mountain Lion blocks by simply doing a right click, and selecting Open, then when asked, confirm that you are sure you want to run it. It will only ask that the first time you run something, then it will work like normal, with no changes to Gatekeeper.
Ensign
Join Date: Jul 2012
Posts: 5
# 2137
07-28-2012, 12:48 PM
Yes, I'd already tried downloading new wrappers. I appreciate your exchange of information, but you're coming off a bit rude when you hadn't provided any actual solutions. I'm providing the solutions that worked, so maybe just a "thank you" and a "gcc isn't necessary" is all you need to say.

I already told people to try just X11 first without the others. And permissions is not the problem.
Career Officer
Join Date: Jun 2012
Posts: 177
# 2138
07-28-2012, 01:42 PM
Quote:
Originally Posted by spacediver View Post
Yes, I'd already tried downloading new wrappers. I appreciate your exchange of information, but you're coming off a bit rude when you hadn't provided any actual solutions. I'm providing the solutions that worked, so maybe just a "thank you" and a "gcc isn't necessary" is all you need to say.

I already told people to try just X11 first without the others. And permissions is not the problem.
Tone can be hard to infer in pure text, I never intended anything to be rude, nor really see how it is rude, but if you see it that way, sorry, it wasn't my intention. My responses on a forum are not always directly to the 1 person, but also taking in mind many other people who may be reading it.

Quote:
[3423093.501] (EE) Error compiling keymap (server-2930)
[3423093.501] (EE) XKB: Couldn't compile keymap
[3423093.514] (EE) Error compiling keymap (server-2930)
[3423093.514] (EE) XKB: Couldn't compile keymap
[3423093.514] XKB: Failed to compile keymap
[3423093.514] Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.
[3423093.514]
Fatal server error:
[3423093.514] Failed to activate core devices.
That happens from a problem not being able to create a symlink in /tmp correctly for initialization (XKB only runs from a hard coded location, so I build it to run from /tmp since its full read/write for all users on OSX). Sometimes its able to make that symlink, but the files in the wrapper do not have the right permissions to launch correctly anyways (usually happens from Migration assistant, or copying apps directly over between Macs without zipping or putting them in a dmg first). Whatever the case, 99% of the time you see those errors, its some type of a permissions problem. The Font errors before that are normal when X11 isn't installed so the X fonts aren't found, but that doesn't stop the wrapper from launching... just may cause Font issues depending on the title, but doesn't cause Font issues in STO. You can completely run STO wrapper without X11 installed on your machine at all.
Ensign
Join Date: Jul 2012
Posts: 5
# 2139
07-28-2012, 02:37 PM
fair enough. Thanks for the added information!

By the way, you don't have Mountain Lion, do you. The Gatekeeper was changed into a much more restrictive program. The change I recommended is required not only for Wineskin, but others too. It wasn't like that in Lion, but it is that way in Mountain Lion now. You can no longer just accept a program that was downloaded from the internet unless it's a signed Mac developer program (until you enable the Gatekeeper setting I mentioned).

Last edited by spacediver; 07-28-2012 at 04:36 PM.
Ensign
Join Date: Jul 2012
Posts: 3
# 2140
07-28-2012, 05:42 PM
I have Mac OS X Version 10.6.8 and I'm trying to install this on my MacBook Pro. I'm using the full download from fileplanet.com but I can't even get the installation going. Every time I click on the setup.exe, wineskin comes back with "no executables found." Do I have a corrupted file? or am I skipping a step or something?
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:46 AM.