Lt. Commander
Join Date: Dec 2007
Posts: 120
# 411
02-09-2010, 03:29 PM
Revenant13
Quote:
Update: Everything works great for me now after enabling UserGLSL...but ONLY in space. As soon as I dock anywhere it crashes constantly. I figured this out last night as I docked one character yesterday and it stopped working, so this morning I undocked him and played a bunch of patrol missions fine. As soon as I tried docking at D7 to do that mission I am crash city.
I also have the 8800GS and I also have this issue. Space works great, especially with GLSL enabled, but Stations are a no-no. I've only docked at two stations but it's definitely "crash city" each time I do. I don't have Windows to fall back on so I have had to get unstuck myself, and I have found that if I log in at non-peak (almost ghost town) times, I can move around stations and interact with NPCs. So I can log in at 4AM CST and beam to my ship real quick like.

Glad to see someone else with the same graphics card as I have is having this issue. It means that there will be a fix someday.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 412
02-09-2010, 05:58 PM
You're right it didn't actually hang but it took over an hour to get past that, and another hour to finish, but it runs well now.

The only gripe I have is the rotation of the 3D camera. In space it can get really bad when Im in combat and Im trying to look at my enemy, but it resets the camera for some reason when I get to a certain view. i don't know if this has been talked about before. I have this same issue under Crossover.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 413
02-10-2010, 06:20 AM
Quote:
Originally Posted by TheRealWes
Revenant13


I also have the 8800GS and I also have this issue. Space works great, especially with GLSL enabled, but Stations are a no-no. I've only docked at two stations but it's definitely "crash city" each time I do. I don't have Windows to fall back on so I have had to get unstuck myself, and I have found that if I log in at non-peak (almost ghost town) times, I can move around stations and interact with NPCs. So I can log in at 4AM CST and beam to my ship real quick like.

Glad to see someone else with the same graphics card as I have is having this issue. It means that there will be a fix someday.
I'll third this one! I'm running an iMac 3.06GHz Core 2 Duo with the 8800 GS. The game runs beautifully through the wrapper - until I dock at Earth Spacedock. Then STO crashes, and any attempts to re-log (since I'm now at Spacedock) also crash.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 414
02-10-2010, 08:23 AM
Quote:
Originally Posted by gmask1 View Post
I'll third this one! I'm running an iMac 3.06GHz Core 2 Duo with the 8800 GS. The game runs beautifully through the wrapper - until I dock at Earth Spacedock. Then STO crashes, and any attempts to re-log (since I'm now at Spacedock) also crash.
apparently this happens when not running in WINE as well.

http://forums.startrekonline.com/sho...50#post2021850

coderangers fix is to lower world detail for now.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 415
02-10-2010, 09:35 AM
I'm delighted to report that my ATI Radeon 4870 responds beautifully to having GLSL enabled. Space and ground missions have been entirely flawless, graphics turned up high. I've got my bumpy textures back again! Haven't yet tried visiting spacedock, but almost everything else is super smooth (turning on anti-aliasing slows things down a bit, but I hardly notice the difference).

Thanks, doh!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 416
02-10-2010, 11:04 AM
Not directly related but I saw this today and thought of the unofficial Mac client: If anyone is looking for an alternate icon for the client, The Iconfactory released some very nice Star Trek freeware icons yesterday.

Download/info link: http://iconfactory.com/freeware/preview/tkno
Preview of all the icons: http://twitpic.com/12eyft
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 417
02-10-2010, 01:30 PM
Nice work! I got this to work great not only with STO, but also Champions

Easiest way to launch Champions is to set the "Show all Games" option in the STO launcher (which you then need to restart). Champions will then be available in a pulldown list at the bottom. Select it, wait for the patcher to take a look, and then hit Engage =)

Is there any support at all in WINE for the XBox 360 controller? I prefer to use it in Champions, and right now (unsurprisingly) it doesn't work with this method.

I'll also report that it works fine for me both with and without the GLSL setting, but the visuals are much better WITH GLSL enabled because of the shaders. It does take a lot longer to launch either game the first time with this setting though while the shaders are compiled.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 418
02-10-2010, 01:46 PM
Quote:
Originally Posted by cbackas View Post
Nice work! I got this to work great not only with STO, but also Champions

Easiest way to launch Champions is to set the "Show all Games" option in the STO launcher (which you then need to restart). Champions will then be available in a pulldown list at the bottom. Select it, wait for the patcher to take a look, and then hit Engage =)

Is there any support at all in WINE for the XBox 360 controller? I prefer to use it in Champions, and right now (unsurprisingly) it doesn't work with this method.

I'll also report that it works fine for me both with and without the GLSL setting, but the visuals are much better WITH GLSL enabled because of the shaders. It does take a lot longer to launch either game the first time with this setting though while the shaders are compiled.
thats cool... not sure why the glsl being on crashes the game for me.. might just be a Geforce 9000 series issue.

Wine doesn't have much, if any at all... support for USB at the moment. I can use things already seen by the system, but not directly. I've never really gotten any joysticks or game pads functioning correctly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 419
02-10-2010, 04:40 PM
nm, fixed my issue...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 420
02-10-2010, 06:16 PM
Excellent Job!
This runs great on my 2.33 Core 2 Duo Macbook Pro running 10.6.2.

Keep up the great work.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:35 PM.