Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
Before the big patch on the 20th/21st, Beam: Target Shields II seemed to be working fine on my Escort ship.
After the patch, whenever I activate it, it fires, does it's effect and then locks the phaser or beam weapon that was used for 4 seconds, but the tooltip and other information for the ability doesn't say that this should be happening.

I assume it's a bug, or does this skill now cause that sort of cooldown? If it is meant to cause that cooldown, that helps me decide which bridge officer to use since that delay makes 1 of my ship's 3 forward weapons useless when I'm closing on an enemy.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-22-2010, 03:07 PM
It did that before, too, you probably just didn't notice. I'm assuming WAI.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-22-2010, 03:13 PM
It has always done this, from the time I joined closed beta. But that doesn't mean its working right though. It makes absolutely no sense, no other beam powers shuts down your beams, even beam overload just drains power.

As a science ship captain in CB, I simply ignored my subsystem targeting powers because of this. The ridiculously long cooldown makes them entirely pointless.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-22-2010, 04:10 PM
Yeah I never understood this. you are not overloading your shots. so why the cool down it does not make

sense.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:32 AM.