Rihannsu
Join Date: Jun 2012
Posts: 723
# 21
07-03-2013, 07:13 AM
If the shields are bugged that would hopefully explaine why I went from full shields and hull to boom in about 5 seconds in PvE, Tau Dewa patrol when I tried out the thaloran pulse. I wasn't sure, but I think I only had one or two NPCs shooting at me. On the plus side, I did manage to get the tholian carrier I was aiming for to about 50 percent hull.
Joined September 2011
Nouveau riche LTS member
Lt. Commander
Join Date: Jul 2012
Posts: 214
# 22
07-03-2013, 07:29 AM
Glad I stopped by before I bought it, I definitely wont be now until its fixed.

Also the drifting thing is common on large ships coming out of impulse and heavier escort/hybrids like the Fleet Tor'kat when they turn.
Career Officer
Join Date: Jun 2012
Posts: 77
# 23
07-03-2013, 07:42 AM
lol the interia is normal pretty much the same as the bortras, but when 1 probe can take your shield facing down and take 40% of your hull in one hit with tt supposedly running thats a head scratcher.
Empire Veteran
Join Date: Jun 2012
Posts: 1,251
# 24
07-03-2013, 08:07 AM
Quote:
Originally Posted by daggermoon View Post
lol the interia is normal pretty much the same as the bortras, but when 1 probe can take your shield facing down and take 40% of your hull in one hit with tt supposedly running thats a head scratcher.
Agreed,

It feels like I'm using wet paper bags has shields on my Scimitar.

Another Bug that I'd like to point out is that some times the Romulan Drone ship when it copies Borg probes will get to into its new roll and will start firing on me.

The Drone Ship firing on me only happened twice and both times were on ISE.
Lt. Commander
Join Date: Jul 2012
Posts: 113
# 25
07-03-2013, 08:35 AM
Anyone feel the Thalaron weapon is crap??? I mean you spend 12 seconds without using any abilities getting pounded waiting for the damn thing to charge only to have it do 10k dmg ? sometimes less, cause there shields are up ? Im sorry but Donatras thalaron weapon doesn't take 12 seconds to charge I think and it does a hell of a lot of damage. This weapon should be a 1 **** kill weapon, no matter what, its what it was designed to do decimate everything. The tholians have a similar weapon on their tarantulas and the NPC scimitars in NWS also do massive damage with their thalaron weapons so what is going on with ours??


I have also noticed that I am unable to use any science/eng skills while cloaked, not 100% sure if that is normal, but on my tvaro I can pop all my skills prior to decloaking don't know if that's because of the enhanced cloak vs the battle cloak.
Captain
Join Date: Apr 2013
Posts: 1,014
# 26
07-03-2013, 08:48 AM
Quote:
Originally Posted by rathsartaro1 View Post
Oh yeah, and the crew thing. It takes the full timer after a stf, then a
couple of mins in real space for it to regen to 3000. Only for you to lose
them all in a couple of hits
That's not a bug, I have the same problem, with a 2000 crewman Mirror Vo'Quv. I saw on one thread a while ago, that taking weapons fire seems to have %-based crew damage potential, rather than a # based. While I could agree, that in a larger crew-complement ship, weapons fire would produce a few more casualties, than a smaller crewed ship, I though it was ridiculaous, that in the same circumstance, my Fed in a patrol escort will lose only 100 people, my Feds in Fleet Excelsiors lose like 200-300 people, and my KDF in a Mirror Vo'Quv loses over 1000 personnel.
In summary, the whole crew damage/deaths to weapons fire needs to be fixed for ALL ships, not just the new Scimitars, you're just seeing it more in your face, than probably before, with the Scimitar having such a large crew complement.

butcher suspect, "What'd you hit me with?"
Temperance Brennan, "A building"
Captain
Join Date: May 2013
Posts: 2,162
# 27
07-03-2013, 08:54 AM
YOU people realize one BIG thing right??

Standing still - AKA firing the weapon = Negative -15% defense

this drops all resists - this makes you blow up if hit by most things

This is standard for ALL ships - when stopped dead in space( negative - defense)
Lt. Commander
Join Date: Oct 2012
Posts: 191
# 28
07-03-2013, 09:17 AM
I posted before in a thread of mine that this ship appeared to be op on paper, but after testing it in game. It is far from op. Yes I was moving, yse my shields were at full power, yet my hull was melting away at a extremely fast rate. No I did not have a burner on my hull, nor was I being hit by torps. Just regular weapons fire, and my ships was loosing hull percentage extremely fast. I do not see any dev burning themselves by putting out a gimped ship like this, it would only ensure no one ever again buys from the zen store. My guess is its a bug, given the state of the interior, I am guessing they rushed this ship out too fast, and its bugged.
Survivor of Remus
Join Date: Jul 2012
Posts: 210
# 29
07-03-2013, 09:29 AM
Wow I haven't experienced any of the things you are mentioning... yet.
Rihannsu
Join Date: Jul 2012
Posts: 3,385
# 30
07-03-2013, 09:46 AM
Quote:
Originally Posted by newromulan1 View Post
YOU people realize one BIG thing right??
And you do realize we would not talk about this if we werent sure.

And no defense means one thing, being hit or not ... does not explain the wild spike damage of things like Warp Core explosions that are AoE damage.
Romulans ...
You start your career off as a simple farmer... then you launch yourself into a galaxy filled with intrigue, power plays, and high stakes games of interstellar conflict, as your career careens upwards onto your final destination ... a level capped Dilithium and Fleet Mark Farmer!
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:39 PM.