Ensign
Join Date: Jan 2013
Posts: 17
Fire the team who writes your patches, and then fire the people who implement them, because I've lost access to too many special events and just general game play time to this bullcrap over the last six months. Every single time a patch comes out, I know that I won't be able to play the game because it's broken until the tech monkeys fix it in 2-48 days. Every. Single. Freaking. Time.

I'm serious, it's time to start giving people the axe because they are not performing adequately at their job, and it's not like you can't find another team of patch writers in this economy. America and abroad are literally drowning in unused talent right now.

The worst part is? I won't be getting free ships because of this. Which, no, is not entitlement rearing its ugly head. The giveaway, while nice, is a marketing and PR ploy, and it's completely inaccessible to me for reasons completely beyond my control! An opportunity lost through no fault of my own stings twice as hard as when it's my own **** up. Oh, yeah, there's the regret, but there is also justified anger at the manifest unfairness of it all.

If I was a more paranoid person, I'd seriously suggest that the devs and techs timed this out so that they wouldn't have to give away potentially thousands of dollars in digital merchandise! But I'm not, so I'll just stew angrily about the shockingly bad (egregious) timing of it all, and hold onto this incident as nourishment for a budding grudge.
Career Officer
Join Date: Jun 2012
Posts: 1,327
# 2
08-16-2013, 07:05 PM
I've had the same problem. I've been posting the same thing after every patch and I get nothing. The problem: THEY DON'T CARE. The only customers they give half a **** about are the transient ones who max level in a day, spend some money in game, and leave. LOYALTY DOESN'T FACTOR IN. And they have NO idea what Star Trek is or what it's about. Or, sadly, the impact it has had on so many people over the decades. Fandom isn't important. This STO will likely prevent a better Trek game from being developed in the future. I sincerely hope there isn't another one. When this one dies, the franchise will regain some of the dignity this game has stripped it of. **** PWE.
Super Moderator
Join Date: Jun 2012
Posts: 2,687
# 3
08-16-2013, 07:26 PM
If you're having issues after every patch something else is up as thousands of players can play after the majority of patches. I would make a full post on http://techsupport.perfectworld.com (where the actual tech team for PWE is) on what it's doing, exactly where it errors and so fourth.
Volunteer Community Moderator for the Star Trek Online forums
My views may not represent those of Cryptic Studios or Perfect World Entertainment
If you wish to speak to someone on the community team, file a community support ticket here, as we are not able to respond to PMs regarding moderation inquiries.
Contact: Twitter | Line Messenger: askray113
Ensign
Join Date: Jan 2013
Posts: 17
# 4
08-16-2013, 10:43 PM
Well, I will admit that some of my post was hyperbole used to emphasize my grievance. Not EVERY patch poses problems for me and hundreds of others, but enough of them do, and almost always during content additions or special events; that is particularly irksome. I could not play for two entire weeks upon the launch of the LoRom expansion, and even with officially submitted problems it still took two weeks, and I had to endure snotty remarks from lifers about freeloading and inferences that I was a parasite.

It could just be confirmation bias, but when things go wrong with this game, they go wrong at the worst times, and in the worst ways. And nothing is ever said about it by the those in charge of the games, which only makes things worse, since it engenders a sense of helplessness.
Lt. Commander
Join Date: Apr 2013
Posts: 248
# 5
08-16-2013, 11:54 PM
This guy just likes hearing himself talk.
Rihannsu
Join Date: Jun 2012
Posts: 812
# 6
08-17-2013, 12:36 AM
Askray's right, tens of thousands of people are able to play with no problem after these patches, if it was really as huge of a problem as you make it sound, there'd be a lot more complaining on the forum.

Relax a little and think, if no one else is having these issues after "every" patch, maybe there's something wrong on your end. Have you actually tried filing support tickets? How about reinstalling, or force verifying. Cryptic isn't trying to break the game with every patch, what use would that be?

You suggested that they are trying to keep people from participating in their special offers and events, why would they do that? PWE/Cryptic aren't idiots, they know that's bad business. Think about it, why do companies offer sales, or free giveaways? It's not just to hand out free stuff, they want you to get your foot in the door, they want you to come, get the free ship and then spend $50 bucks on that fancy Scimitar while you're there. Why would they intentionally break the game to prevent you from having the opportunity to maybe make them some money?
Ensign
Join Date: Jan 2013
Posts: 17
# 7
08-17-2013, 03:22 PM
Okay, then, no. It's not on my end. It's the patch server. I keep losing connection with it. It could be the whole Verizon internet squabble, but I doubt that. It's more likely related to the fact that that both NWO and STO share the same patch server, and I say that because the problems for me and hundreds of others started when NWO came online. There are certainly enough topics on the support board to back me up on this. It's a little disheartening.

I get to 61-62% patched, lose the connection, and then it starts over from around 56%, then it works its way up after a couple of minutes, loses connection again, and then begins the cycle all over again.
Super Moderator
Join Date: Jun 2012
Posts: 2,687
# 8
08-17-2013, 04:47 PM
Quote:
Originally Posted by paxinae View Post
Okay, then, no. It's not on my end. It's the patch server. I keep losing connection with it. It could be the whole Verizon internet squabble, but I doubt that. It's more likely related to the fact that that both NWO and STO share the same patch server, and I say that because the problems for me and hundreds of others started when NWO came online. There are certainly enough topics on the support board to back me up on this. It's a little disheartening.

I get to 61-62% patched, lose the connection, and then it starts over from around 56%, then it works its way up after a couple of minutes, loses connection again, and then begins the cycle all over again.
Again, thousands (and if you're putting NW into this bracket hundreds of thousands) are having no issue. The verizon squabble could easily be it or it could be something else however the patch servers are obviously working fine. You would need to run the diagnose methods stickied in this forum to have any luck in any of us helping

You could also try using the proxy option to see if it gets past whats hiccuping.
Volunteer Community Moderator for the Star Trek Online forums
My views may not represent those of Cryptic Studios or Perfect World Entertainment
If you wish to speak to someone on the community team, file a community support ticket here, as we are not able to respond to PMs regarding moderation inquiries.
Contact: Twitter | Line Messenger: askray113
Captain
Join Date: Jun 2012
Posts: 622
# 9
08-17-2013, 05:01 PM
While the patching issue resolved for me a few hours after beginning, I would balk at throwing Verizon or any ISP under the bus for the simple reason there are at least six other MMO/RTS or RPGs with online multiplayer support I play that do not have the same "significant" patching issues.
All cloaks should be canon.
Lt. Commander
Join Date: Aug 2012
Posts: 147
# 10 Let him rant...
08-17-2013, 06:01 PM
Excellent OP. Well written.

I would imagine 90% of peeps are like me and hope someone else will file the ticket.
"Must already be a hunderd complaints, they don't need mine too".
Just because we're not complaining, doesn't mean we're happy about it.

You can only get so many crashes / "what were you doing at the time?"
windows before you just hit cancel, or type in "whatever",
or who cares what I was doing,
"where's my photonic displacement, and missing mail!"
(That method actually seemed to work for me).

Things being dumped into your trays automatically...even with lock tray on...sheesh.
Really? If something like that can't be fixed inside of 2 weeks someone needs to be fired!
It's called just do it or we'll find someone who can. AKA, Flame under butt method.

But hey, lets spend time on changing graphics on the consoles...

"and hold onto this incident as nourishment for a budding grudge."

Thanks for the op.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:03 AM.