Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Hotkey Keybinds stop responding
01-26-2010, 03:01 PM
Didn't see a post for this if it's duplicated I appologize.

Some times all hotkey keybinds stop working for no apparent reason. This has happened in space combat as well as in ground combat / interaction. The only fix seems to be logging all the way out (quitting the client) and back in.

examples:
Space combat, hotkeys for movement, speed, and weapons stopped responding. I could perform the actions by using the mouse to either fly (both buttons at once) or click on the specific hotkeys I wanted, such as clicking the phasers button to fire them.

Ground interaction, Sol system starbase. Unable to interact with NPC's though movement control still functioned.

Ground interaction, combat, unable to use the aim mode. Pressing C had no effect. Other hotkeys functioned correctly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-02-2010, 04:45 AM
BUMP - I have an ongoing problem along these lines. Ticketed, but no response as of yet.

Mostly for me, it seems to be the numbered shortcuts for hotkeys - 1-0. They will randomly stop working in both space and ground combat, relog does not fix the problem - only a complete restart of the client. They are fully working on restart, without any need to rebind (thought I had unbound them somehow, crazy key combo etc.).

The hotkey icons can still be clicked, and hitting "fire all XXX" does fire weapons - almost everything else seems to be working fine. I can fly ships and move captains, and I can even use the ALT+Num and CTRL+Num hotkeys - just not those that are number keys only, i.e. the most important ones lol

I really think this is the SHIFT key getting "stuck", or something similar. When it happens, I also struggle to left-click target - it bounces right back to my last target, or "Ally" or "Enemy". Also, pressing R accelerates to full speed in sector space, pressing R again does NOT stop the ship - making me think it's trying to toggle full impulse when it isn't available, hence the shift key stuck thoery. It does make the sound effect for engaging full impulse too.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-05-2010, 12:59 PM
This is still happening to me and my friend! It's a real downer when it happens too!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-05-2010, 01:22 PM
this may happen if you are alt-tabbing -- those keys are getting stuck on other programs

try alt tabbing a few times and clicking in windows and back into the game....this happened to me in warhammer a lot too
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-05-2010, 02:29 PM
Quote:
Originally Posted by eoddc5 View Post
this may happen if you are alt-tabbing -- those keys are getting stuck on other programs

try alt tabbing a few times and clicking in windows and back into the game....this happened to me in warhammer a lot too
I am not alt tabbing I play in full screen, and have my laptop sitting next to me if I need anything out of game. I have recently noticed that some times the issue will occur, and once you leave the "zone" and re-enter, sometimes the issue is resolved. I'd say that happens about 15% of the time currently.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-05-2010, 02:36 PM
Quote:
Originally Posted by Thail.DL View Post
Didn't see a post for this if it's duplicated I appologize.

Some times all hotkey keybinds stop working for no apparent reason. This has happened in space combat as well as in ground combat / interaction. The only fix seems to be logging all the way out (quitting the client) and back in.

examples:
Space combat, hotkeys for movement, speed, and weapons stopped responding. I could perform the actions by using the mouse to either fly (both buttons at once) or click on the specific hotkeys I wanted, such as clicking the phasers button to fire them.

Ground interaction, Sol system starbase. Unable to interact with NPC's though movement control still functioned.

Ground interaction, combat, unable to use the aim mode. Pressing C had no effect. Other hotkeys functioned correctly.

I have asked 2 or 3 times about the hot keys for phaser firing ... no one seems to be listening. I also sent in a bug notice as well. That was a couple of days ago .. before the latest patch. Some how I'm guessing no one is listening for now. It really is annoying to be in a good ground fire fight and realize that your primary fire button is missing. Sooo we hit the "p" key .. bring up the list of actions and drag it back into the #1 slot .. EVERY time we have an away mission.

That problem did not exist during OB.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7 Me too
02-07-2010, 11:49 AM
I have this same problem on the ground as well. I've not had it in space, but every time I beam to the ground there is nothing in the 1 or 2 slots. I accidentally dragged the number 1 fire skill out of its slot once, and then put it back. Now 1 and 2 are missing EVERY time I'm on the ground. Very annoying. I also have a ticket for a couple of days with no response. I sure hope they can figure out a fix soon as this is a huge pain in the patuti.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-07-2010, 12:21 PM
I have this problem with slot 1 every time I beam down. I replace it and sure enough its gone next time. Its the default phaser setting
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-07-2010, 12:41 PM
having the hotkeys disappear is a slightly different problem than the one that I've encountered, as for the issue I've had, the hotkeys are still there, but the keybinds stop triggering them.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10 yea
02-07-2010, 01:00 PM
I had this happen twice so far. What is happening, is the game thinks that keyboard 1 is actually alt + 1.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:10 AM.