Go Back   Star Trek Online > Information and Discussion > Star Trek Online General Discussion
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
01-29-2010, 01:41 PM
Quote:
Originally Posted by Ragerx
So its not Beta its live so whats the apologists excuses now?
Everything is working great? It's a heck of a lot of fun and it was deterring me from doing homework that I have to get done today. No problems here.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
01-29-2010, 01:51 PM
It's a better launch then most of the other MMO's I have played. However people seem to think whenever a new MMo comes out that all other MMO's before it had magical care-free launches.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
01-29-2010, 01:54 PM
You think cryptics server load anticipation is fail you should have seen blizzards. Blizzard turned there 3 year server upgrade plan into a 3 week server upgrade plan. They had to rush by servers in mass to meet the need. They where off by a huge amount.

I have also seen games go the other way and thats worse, when they launch with 10 servers get everyone spread out people complain about areas being devoid of people and the world seeming barren and leave then a few months later they combine the servers down to 3 to try and fix it. Its not an exact science and its a lot harder then you would think.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
01-29-2010, 01:55 PM
Headstart, MMO launch. Nuff said.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
01-29-2010, 04:48 PM
Well we have our new excuse then:p
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16
01-29-2010, 05:21 PM
Same rubber banding and server DC'ing we saw in the Beta. Had 2 weeks to fix it (that's what an OB is for) and they couldn't even do that. Not a good start.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
01-29-2010, 05:26 PM
Quote:
Originally Posted by Jesus69
During OB, Cryptic said that they are installing new hardware, so we will not get this “Server not responding” + 40k ms ping any more.

I guess that the new hardware have not arrived yet , so we shall patiently wait for it to be installed.

You are so lame….it’s a rip off.
All you have to do is to tell us the f u ck ing truth , that’s it, no more ..no less.
But no , you choose to ignore your potential future customers.

That’s not the way to conduct a business, that is your way down the hill.
Are you going to post the same thing in every thread?

Any ways...This launch has been MUCH better than Champions Online. I'm not ready to judge the game quite yet, but so far it has been fun.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
01-29-2010, 05:27 PM
And with this, my OB theory of "some of you will find anything to ***** about" has been confirmed. I shall now go celebrate by drinking some hot tea and cooking a burrito.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
01-29-2010, 05:29 PM
I realy dont see the problem I had NO issues when i was playing earlier with a little bit of lag exceptions when there were 10 billion ppl in the tutorial. Honestly if you realy dont like the game then dont play it and send a message to the cryptic team instead of filling the forums with garbage.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 20
01-29-2010, 08:22 PM
Quote:
Originally Posted by Ragerx
So its not Beta its live so whats the apologists excuses now?
Let's see :
  • It's prelaunch
  • Every MMO sucks at start
  • The bugs don't exist, fix your computer / connection / whatever
  • If you don't like it, don't play it
  • Be patient Cryptic will fix it eventually
  • This is woooooooooooooooar
  • This *was* beta
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:02 PM.