Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
01-29-2010, 02:35 PM
Quote:
Originally Posted by Zorac
Excellent.

I am waiting for the Del Taco Servers to reboot, though.

I'm currently being routed to one on the other side of the city 8(
Heard they were down about the same time as the cstore
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
01-29-2010, 02:36 PM
Quote:
Originally Posted by Bookreader
fun, worth my money

no lag and tons of people
Boo Hoo (In regards to your sig)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
01-29-2010, 02:36 PM
Quote:
Originally Posted by The_Happy_Stromboli
I'm currently waiting on Steam to update STO. ETA 50 min. How's the game been for everyone so far? How's everything running?
I had a real fun 3 hours till a zone crashed, then got kicked out. Then of course got bitten by Steam

But yeah was just fine and dandy (apart from Zone chat as usual). Enjoy it when you get in
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
01-29-2010, 02:37 PM
Quote:
Originally Posted by bodean
Boo Hoo (In regards to your sig)
boo hoo

in regards you having no sig
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
01-29-2010, 02:37 PM
Quote:
Originally Posted by DraigUK View Post
I had a real fun 3 hours till a zone crashed, then got kicked out. Then of course got bitten by Steam

But yeah was just fine and dandy (apart from Zone chat as usual). Enjoy it when you get in
I feel sorry for people with steam
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16
01-29-2010, 02:39 PM
Quote:
Originally Posted by Bookreader
I feel sorry for people with steam
Yar it is a pain, but not that much of a big deal. I was watching some opera on TV and there was less drama on the show than on these forums.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
01-29-2010, 03:09 PM
Quote:
Originally Posted by Bookreader
I feel sorry for people with steam
Yeah my download is almost done...45 minutes.....just went to dinner and came back...no biggie
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
01-29-2010, 03:11 PM
Quote:
Originally Posted by The_Happy_Stromboli
I'm currently waiting on Steam to update STO. ETA 50 min. How's the game been for everyone so far? How's everything running?
Everything is running smooth and fine. Taking break after 2 hours of gameplay. Not a single crash or disconnect. Quite impressive.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
01-29-2010, 03:15 PM
Played for a few hours, game running well. No bugs. Little lag here or there (some rubber-banding). Overall good performance on somewhat old hardware. Compared to the absolute horror stories of launches for other MMOs, this has been spectacular. Borg issues were brief and overall kinda minor (yes I'm lifer and it affected me).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 20
01-29-2010, 03:17 PM
This must be the thread for grownups. Nice to have one
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:16 PM.