Go Back   Star Trek Online > Information and Discussion > Star Trek Online General Discussion
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
GREAT JOB DEVS for a smooth and successful launch!

Now granted this is a soft launch (head start) with the real server load happening on Feb 2. However in all my 14 years + of MMO gaming, testing, and even some reviewing; Star Trek Online has had perhaps one of the smoothest launches I have experienced in any MMO. It takes a lot of work and not a little luck to have a good MMO launch, unforeseen server loads, hardware failures, software issues all always seem to creep up and render most MMO launches so bug ridden usually at least an hour or 2 if not the entire day of a players game time is wasted or lost due to crashes, lag, and connection issues.

Hell Star Wars galaxies could not even get the website registration right, it took hours on launch day 3 different web browser attempts and then still when I finally got on to Corbantis after hours of trying to get the game working, the game crashed so hard all progress was lost and the game server had to be actually wiped.

I just mentioned SWG in comparison because well you cannot please everyone, and certainly not gamers who will nitpick and declare STO’s launch a failure just because preorder bonuses are unavailable until Feb 2, or it took Cryptic all of an hour to fix the Borg officer issue. All such things are relatively minor and should be expected.

For anyone wanting to debate the success of STO’s launch with me I ask just a few questions…

1.How long did it take to log in? (For myself under 5 minutes)
2.Did Character creation work? (For Me it worked perfectly)
3.Could I complete the tutorial? (For Me again yes, it was a breeze and I was not disconnected even once.)
4.Did I enjoy playing the game and how long did I play without a game ending crash/event? (Again for myself I have had a blast, all but 1 quest functioned properly and the one was a missing reward of an officer I did not need. I gamed with my friend using Ventrilo for 11 HOURS straight. I was disconnected 2 times and after each I could immediately reconnect.)

Did I get a bit of rubber banding on occasion, did I get a hiccup in load times every once in a while? Sure it happens in every MMO, especially during its first few months live. What I can say is Devs, Cryptic, and Atari... THANK YOU... thanks for giving me a great day of fun with my oldest and best friends, good job all your hard work has paid off in spades.

Sincerely,
Doug
aka JEST3R
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-29-2010, 09:36 PM
*ignores the gazillion hate threads from people who use Steam*

Hurray for a 100% painless launch!!!!

*returns to reality*
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-29-2010, 09:39 PM
It's the best Cryptic launch, but that's everything I would dare say about it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-29-2010, 09:41 PM
Quote:
Originally Posted by Arsilon
*ignores the gazillion hate threads from people who use Steam*

Hurray for a 100% painless launch!!!!

*returns to reality*
The problem with steam is steams own doing not Cryptics Steam manages to single handedly screw up every single MMO they offer.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-29-2010, 09:44 PM
Quote:
Originally Posted by storm_dragon View Post
The problem with steam is steams own doing not Cryptics Steam manages to single handedly screw up every single MMO they offer.
I have never heard of this problem from COH, CO, EVE, ***, or any other MMO where a 10GB file disappeared. Granted I've only bought a few through Steam, so maybe this problem exists. CAn you post a link to this happening.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-29-2010, 09:47 PM
You do realize Cryptic has NOTHING to do wth that piece of trash called Steam. I have avoided steam like the plague ever since I first was forced to install it to play Dawn of War 2.

Steam is a piece of GARBAGE, I would recommend instead buying from Atari or D2D.

I feel the pain of those dealing with steam at the moment and if your STO is still not properly working, just search for a STO torrent from open beta and patch up instead.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-29-2010, 09:52 PM
Can't wait for february 2nd, I hope my first log in will be as smooth as yours OP.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-29-2010, 09:53 PM
Actually I have not had a problem with Steam on any other game. I think it's more of a verson issue of some kind. There is no way around it so I'll download it tonight, and then apparently again in the morning, and maybe sometime next week will have a working client.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-29-2010, 09:56 PM
I have the same issue and didn't use Steam. ***The issue is not with Steam***
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-29-2010, 10:01 PM
Quote:
Originally Posted by storm_dragon View Post
The problem with steam is steams own doing not Cryptics Steam manages to single handedly screw up every single MMO they offer.
It'd be nice if people actually read Full_Metal's thread rather than bash Steam because it's just easier to do, he actually knows what he's talking about. It's even been forwarded to the dev team because it's something Cryptic did.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:51 AM.