Lt. Commander
Join Date: Dec 2007
Posts: 120
Is anyone else noticing that about 20-30 % of mission rewards never actually end up in your inventory?

It happened in OB, and it is happening now.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2 yes
01-30-2010, 03:30 AM
IIt happened to me on one mission. Fortunately, later I was able to do another mission and got a better version of the missing item.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-30-2010, 03:34 AM
Can't say I've had that problem, except for the Officer Requestion now and then.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-30-2010, 03:58 AM
Yes, I missed out on the BO from the SS Azora mission (before anyone asks, I checked the assignments window; the BO was not there).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-30-2010, 03:59 AM
Quote:
Originally Posted by Amagonn View Post
Is anyone else noticing that about 20-30 % of mission rewards never actually end up in your inventory?

It happened in OB, and it is happening now.
I find that handing in missions on the Bridge or otherwise outside of Sector Space will increase chances of the items actually appearing.

This issue was also in Beta, I'm disappointed that Cryptic still haven't fixed it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-30-2010, 04:00 AM
I'm having similar issues, not frequently but a few so far.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-30-2010, 04:00 AM
that bug ate my lvl 6 special boff.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-30-2010, 04:01 AM
Quote:
Originally Posted by mathcube View Post
Yes, I missed out on the BO from the SS Azora mission (before anyone asks, I checked the assignments window; the BO was not there).
Same here. But only for that mission. I've had the rewards (including Bridge Officers) appear for all the rest I've done so far.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-30-2010, 04:28 AM
I do not know if this has anything to do with it, however ever since this started happening in Open Beta, I have always opened my Inventory prior to accepting the reward. Or opened my Assignments tab prior to accepting the Bridge Officer. Since launch, and sitll doing this, I have yet to not receive my chosen reward.


Now watch me get hit with this since I said something... lol

*knocks on some wood*
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-30-2010, 05:12 AM
Quote:
Originally Posted by Captain Zebular
I do not know if this has anything to do with it, however ever since this started happening in Open Beta, I have always opened my Inventory prior to accepting the reward. Or opened my Assignments tab prior to accepting the Bridge Officer. Since launch, and sitll doing this, I have yet to not receive my chosen reward.


Now watch me get hit with this since I said something... lol

*knocks on some wood*
I'll try this. And turn in the corresponding missions on the bridge or in Sector space.

Because honestly... I never got any blue BO during beta (made it to Co5, should've got 3-4).

Now I've already been denied my green lv6 BO. But this is release. It's going to make my character lag behind if I don't get those BOs. All of you too, we'll have super-weak teams

Please Cryptic do something so we get them BACK if the bug happened to us. Loop the quest until it checks that the BO is in assignments or something... This is becoming to be a showstopper to me. If rewrads don't work, then put the missions offline alltogether, or else it makes no sense to play for nothing... it ruins any form of competition or achievement. It ruins the pleasure to hire/take care of your crew. It just ruins a big part of this game: BOs.

*Disappointed by such important bugs.* :cry:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:14 AM.