Career Officer
Join Date: Oct 2012
Posts: 54
# 1 Zen / customer service broken
11-13-2013, 09:37 PM
I got me some Zen, it charged my card and it's been in review for 2 days now.

I've called off and on to the support number for four hours earlier today and it said they were too busy and call back later...for four hours?

Tried to use the contact us link on the zen page and just times out WTF?

The key sale is almost over and im a wee bit pissed. If there are any real PWE employees that can tell me when the best time to call to get this resolved, I would appreciate it.
Ensign
Join Date: Jul 2012
Posts: 8
# 2
11-14-2013, 04:13 AM
Quote:
Originally Posted by luvsto1701 View Post
I got me some Zen, it charged my card and it's been in review for 2 days now.

I've called off and on to the support number for four hours earlier today and it said they were too busy and call back later...for four hours?

Tried to use the contact us link on the zen page and just times out WTF?

The key sale is almost over and im a wee bit pissed. If there are any real PWE employees that can tell me when the best time to call to get this resolved, I would appreciate it.

I'm glad I'm not the only one suffering from the broken 'contact us' link! i brought it up here; http://sto-forum.perfectworld.com/sh...d.php?t=914671
Lt. Commander
Join Date: Jul 2012
Posts: 188
# 3
12-18-2013, 01:20 PM
Same problem, wont stop reviewing.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:05 PM.