Go Back   Star Trek Online > Information and Discussion > Ten Forward
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
faster than outposts along the neutral zone. Is that some terms of service violation or what? They seem to be specificaly ones that involve the Steamrunner / Zephyr class.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-31-2010, 02:48 AM
Server went down bump.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-31-2010, 04:40 AM
I've had a pic of my current ship in my sig since the start of open beta and haven't gotten in trouble.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-31-2010, 06:20 AM
most likely they were just moved somewhere else. you might have to look in the other sections to find them?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-31-2010, 10:42 AM
Here you go. Several ships, including the weird "peace sign" one & the Vigilant-Class (Defiant Refit).

http://www.flickr.com/photos/stofan34/

http://groups.yahoo.com/group/stnewworlds

http://stnewworlds.webs.com
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-31-2010, 10:44 AM
Quote:
Originally Posted by JHauck View Post
Here you go. Several ships, including the weird "peace sign" one & the Vigilant-Class (Defiant Refit).

http://www.flickr.com/photos/stofan34/

http://groups.yahoo.com/group/stnewworlds

http://stnewworlds.webs.com
Nice ones, can I ask what graphic card you are using?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-31-2010, 10:48 AM
No idea. I'm using a Mac. (OS X)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:49 AM.