Lt. Commander
Join Date: Dec 2007
Posts: 120
# 31
02-01-2010, 10:51 PM
Quote:
Originally Posted by Rehpic
Three things...

First off, there were a lot of new players who reported not getting bridge officer rewards, and when we investigated, we found that they had the bridge officer and just didn't know where to look for it. The purpose of Stormy's post was to inform those people, not to insult people who know the game from beta.
Understood, but Stormy's reply is the only reply we've gotten on this issue, ergo it applied to all of us. You shout at the crowd, the crowd hears you. You say 1 thing to the crowd, the crowd assumes you're talking to all of them.

Quote:
Secondly, the patch we pushed this afternoon had a fix for a bug that could cause selectable mission rewards to not get awarded.
That's REALLY nice to know! If only there were some place, kind of official, where you could put this stuff, what has changed in released patches, where we could read it and know that. I don't know what that would look like, but some place to put the notes for released patches.

Sorry for the sarcasm, but it's late, I'm tired, and I'm frustrated. I realize my frustration can't hold a candle to yours, but since I'm paying you to be frustrated, and it's you that's frustrating me, I'm going to call it even

Quote:
Thirdly, if anyone fails to get a bridge officer reward from a mission, please file a bug and post here and include your full character name (name@handle), the mission you were turning in, and the time when the problem occurred (including time zone!) The more accurate the time you provide the better.
I did, each time, plus added "me too" to the sticky bug on this issue, but here you go again:

I have 6 instances of "New Officer", 2 which offered green officers, 4 of which offered blue ones, where the officers vanished somewhere between me selecting "Complete" and them not making it to the Assignments screen. I have no further detail, because the mission has the same name every time, always comes from the same NPC, etc.

As I've posted in other places, this has failed in many different ways:
In a mission, tried completing it when I noticed it...vanished.
In space...vanished.
In sector space...vanished.
On Sol....vanished.
On Sol, talking directly to the NPC....vanished.

I gave up trying when I tried every way I knew how to do it.

I don't know what their skills were, and I don't care. I'd take 6 randomly generated BOff's, just pop that quest for me 6 times and give me 6 rolls of the dice. I'm getting up in rank and it's time to select my final BOffs, but right now I have 2, when I should have 8. I've additional waiting in the queue, quests I've not completed, but if you're telling me here and now that it's fixed, then I'll complete them right now and see what comes of it.

Edit: Sorry, just noticed I'm missing info you asked for...
Thrynn@MacAllen
Missions that failed and when: New Officer
1/31/2010 3:46:12pm (blue)
1/31/2010 7:41:00am (blue)
1/31/2010 7:40:53am (green)
1/31/2010 7:40:11am (blue)
1/30/2010 1:36:38am (blue)
1/30/2010 7:57:44am (green)

I didn't log any of the other details, because it didn't require thinking to accept them, they were single options. 3 of them appeared in assignments then vanished again, within seconds, it was very weird.

Hope this helps.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 32
02-01-2010, 10:56 PM
I have not gotten two Bridge officers from leveling up. I've had to go and use my credits to buy them. I did get one tonight from leveling after the patch. The character name is mark@apinator I don't remember the day or time, it was the first two bridge officers from leveling, I could look through my log if you need me to. I did put in a bug report for the second one.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 33
02-01-2010, 11:00 PM
Quote:
Originally Posted by Rehpic
Three things...

First off, there were a lot of new players who reported not getting bridge officer rewards, and when we investigated, we found that they had the bridge officer and just didn't know where to look for it. The purpose of Stormy's post was to inform those people, not to insult people who know the game from beta.

Secondly, the patch we pushed this afternoon had a fix for a bug that could cause selectable mission rewards to not get awarded.

Thirdly, if anyone fails to get a bridge officer reward from a mission, please file a bug and post here and include your full character name (name@handle), the mission you were turning in, and the time when the problem occurred (including time zone!) The more accurate the time you provide the better.
I posted a bug when it happened.

Consari@Treksplorer

This was a couple days ago...it was that mission you get around level six that has you hail Starfleet to complete the Bridge Officer Requisition mission. I selected a Ferengi Male Tactical officer, he head Beam Fire at Will I if I remember right. He never showed up in my assignments tab. I still haven't gotten that bridge officer. :/
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 34
02-01-2010, 11:01 PM
Quote:
Originally Posted by Rehpic
Thirdly, if anyone fails to get a bridge officer reward from a mission, please file a bug and post here and include your full character name (name@handle), the mission you were turning in, and the time when the problem occurred (including time zone!) The more accurate the time you provide the better.
Matsky@Matsky - I was turning in the mission "New Officer" and did not receive my BO (only one choice showed up, and I couldn't select it). I have done what was suggested, and he is not on my assignments page ready to be commissioned. I know because I've done it before and know exactly where he should be. I can't provide you with the exact time, but the first ticket I submitted says "1 day ago" (I closed it as I joined the stickied ticket, but then I opened another one myself 17 hours ago, that is still open, to have it dealt with). I would really appreciate being able to get to choose my Battle Officer please
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 35 Missing Bridge Officers
02-01-2010, 11:14 PM
Two@BlackMarshG

Offered an uncommon Male Klingon Tactical Officer after New Officer Mission. Not in assignments screen. In space sector Sirrius responded with a hail to Starfleet. Bug report directly after event.

Offered an uncommon Male Bolian Engineering Officer after Kuva Magh (sp?) mission. Not in assignments screen. In space hailing Starfleet. Bug report directly after event.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 36
02-01-2010, 11:14 PM
Please only post the info I asked for here if this occurs from here on out. We want to be sure that our fix today did resolve the problem. Thanks.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 37
02-01-2010, 11:24 PM
Now that we know there is in issue, I went in and completed 5 New Officer missions...all went to Assignments. I asked fleetmates to do the same, zero of them vanished.

It appears that the problem is resolved. Any chance we can get the officers we lost (in my case, 6 more random ones)?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 38
02-01-2010, 11:25 PM
This happened to me and I filed a bug report and requested GM help..

Are they not reimbursed? This was top end and was a quest reward for me.. I really needed the BO and bugs screwed me out of it.. The game is actually considered live too, so it actually matters.. Ultimately, my $50 for the game and $15 a month is going into getting that BO which I got "ripped" off from, among many other things the money got me hehe.. This really is frustrating though... And sad that it is so widespread.

This is a rather big bug to not have fixed prior to launch
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 39
02-01-2010, 11:28 PM
I deleted my toon and restarted to I could go back and pick up my missing BO's.

Now I got the bug that doesn't let your second character pick up the Del Taco shuttlecraft.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 40
02-01-2010, 11:32 PM
Quote:
Originally Posted by Rehpic
Thirdly, if anyone fails to get a bridge officer reward from a mission, please file a bug and post here and include your full character name (name@handle), the mission you were turning in, and the time when the problem occurred (including time zone!) The more accurate the time you provide the better. Please only post this info here if this occurs from here on out. We want to be sure that our fix today did resolve the problem. Thanks.
So those of us who lost Boffs prior to the patch are out of luck? At the time, I subscribed to the sticky bug as that was what we were told to do; it's becoming apparent that that process isn't working.

Just in case: As I remember it, reward was from turning in "Stranded in Space" (SS Azuria), I was in sector space near the Azuria when I called Starfleet to get the reward. Character is Reinhart@Miuramir; my log has the time for mission completion as 1/29/2010 9:21:06pm, and it should be fairly soon after that, and before I subscribed to bug #549649. If the screenshot that's supposed to go with the bug report made it, it should show in the visible chat log that I got the fleet merits, etc. but no officer. (I think I may have even had the Assignment window open to show it not there, but am not sure.)

As a note, it would be incredibly helpful if the auto-screenshot would go ahead and save the screenshots with a normal timestamp, instead of just the tempss.jpg that gets overwritten. That would provide a useful reference with an accurate timestamp that everyone involved could refer to later.

(A further QoL idea might be to go ahead and list the rewards gotten as part of the Captain's Log; this would be handy for a variety of reasons, but also for troubleshooting.)
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:29 AM.