Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
02-02-2010, 10:53 AM
Well posting here does help a bit, now i'm getting a "The Subscription service is temporarily down, please try again at a later time." error.

Still not what i want, but at least its more clear then "There was an error processing your request"
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
02-02-2010, 10:54 AM
they're probably getting hammered.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
02-02-2010, 10:59 AM
I had the same problem for Lifetime Subscription + Borg + 2 Slot Characters.

I received e-mail of confirmation with a number but not of Lifetime Subscription in my account and the credit card was not debited for the moment.

I always received this message...
"Your credit card was declined. Please verify the information you have provided is correct. If you believe this is an error, please try another credit card or contact us for support here."

And with my Paypal account...
"We did not receive payment from PayPal, please contact PayPal support for more information."

My credit card and my paypal account Work perfectly on many other site ... I never had problem before

I contacted the support but they do not answer: (

I want my Lifetime Subscription + Borg + 2 Slot Characters !!!

An answer from Cryptic Please ?

(sorry if my english is bad, i'm French (Belgium)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
02-02-2010, 11:02 AM
your english is perfect better than most i'd say lol
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
02-02-2010, 11:03 AM
Having the same issues here.


Goforce Your post had better english then most of the english speaking folks
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16
02-02-2010, 11:04 AM
grr - Was getting the same "Error processing..." then "Subscription Service is down"... And I can't tell if it accepted my activation key or not - I don't have any additional "keys" listed on "My Account" -- would there be one?

I ordered from Atari, too.. if that helps get an answer...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
02-02-2010, 11:08 AM
After alot of errors and missing transaction ID missing messages i finally got a new message....

This product key is already active, it cannot be used again.

WHAT THE F#CK!!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
02-02-2010, 11:11 AM
i doubt it, though even if they are flooded with subscription requests now, thats not an explaination, i mean, on the first sales day you'll naturally sell the most, not taking sufficient means to ensure every is able to do this, is completely cryptics fault
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
02-02-2010, 11:14 AM
Now it simply sais. "This product key is already active, it cannot be used again." if this ****ed me up... I'm gonna get really ****ed off!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 20
02-02-2010, 11:53 AM
Looks like the did not anticipate (or prepare for) the demand today.
Getting same errors regarding subscription Service being down and/or Billing System offline.
Tried IE8 and Firefox to no avail.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:56 AM.