Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
02-02-2010, 02:44 PM
Quote:
Originally Posted by evanfardreamer View Post
I'm having the same trouble with my billing. I know they said give it 5-10 minutes and try it again; i keep doing that. I'm looking at the card, so I know all the info is right. Everything I've tried has come up failed- dashes or spaces between numbers (in the former, gives an error saying must be number; in the latter, auto-removed them), making sure my email adrs was validated, logging out and rebooting the browser. None of it has been of any avail yet.
Ditto I have tried everything and nothing works. It always tries to save my billing information and when I check it looks like the format is wrong for American Express. I am wondering if you are trying to use American also or if it is just the way Cryptic displays the number once stored. Waiting on ticket response and then will make call.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
02-02-2010, 02:47 PM
Nope, I'm using a Visa card. Part of my worry is that it expires in June, so I was afraid maybe it wouldn't let me start since the card only has 4 months before they send a new one, but i've not heard of anything like that before.

As to the format, I think I was having the same issues - when you'd put in the card info, and went to one of the other recurring options, it saved the card but had a format XXXX-XXXX-####? that's what mine was doing.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
02-02-2010, 02:52 PM
Quote:
Originally Posted by evanfardreamer View Post
Nope, I'm using a Visa card. Part of my worry is that it expires in June, so I was afraid maybe it wouldn't let me start since the card only has 4 months before they send a new one, but i've not heard of anything like that before.

As to the format, I think I was having the same issues - when you'd put in the card info, and went to one of the other recurring options, it saved the card but had a format XXXX-XXXX-####? that's what mine was doing.
Thats exactly what I mean. It worried me so I removed the billing option and started over thinking the system had stored the information wrong. At this point though I have no idea what's going on. My only other guess is that it overbilled the accounts so much they went into autodecline mode. I know my card is valid as I bought some points on Live just the other day and extended my subscription. At least now I get the decline message all the time as if the system is not overloaded and or working properly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
02-02-2010, 02:55 PM
I was also partly worried because my card is first and foremost a debit card - but it has the Visa stamp of approval, and every other online retailer and game has taken it just fine (including City of Heroes, WoW, Age of Conan, Star Wars Galaxies... man, this list makes me sound like a nerd) so I doubt that's an issue. I also thought it might be the 'billing info' section not matching up with my bank, Wells Fargo, so I tried basically every address I've had in the past 8 years, also to no avail.

Good to know I'm not alone, at least.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
02-02-2010, 03:28 PM
I had the same problem for the Lifetime Subscription Offer with the Borg and the Two Slots Character...

I purchased just before the offer expire.

(I have a Mastercard tied with my Paypal account who work perfectly with many other sites...)

I received e-mail of confirmation with a number but not of Lifetime Subscription in my account and the credit card was not debited for the moment.

I don't know what to do

I contacted the billing support but they don't answer : (
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16
02-02-2010, 04:00 PM
I just used a different credit card and it decided to work. The first one was a Visa Gift Card, the one that worked was a MasterCard.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
02-02-2010, 04:02 PM
I'm not sure if i was reading it right but i'm sure its trying to charge my bank card straight away for 30 days even when you get 30 free!!!!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
02-02-2010, 04:05 PM
What the account billing does is try a transaction to the card (mainly 1 doallr charge) to the card to verify it is a valid card (the transaction is refunded)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
02-02-2010, 04:22 PM
Quote:
Originally Posted by MasterShake1441 View Post
I just used a different credit card and it decided to work. The first one was a Visa Gift Card, the one that worked was a MasterCard.
Unfortunately, I don't have another card I can try using. It was one of the first things I thought of.

And it's probably a good thing they don't have the game cards out - last thing I want to run across is that spending another $15 still won't get the account set up.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 20
02-02-2010, 04:55 PM
Well I just got off phone with American Express and they are telling me it's a Billing issue with Cryptic as nothing has been charged to my account and it just declines it every time. Again nothing is wrong my card is fine but it will not accept it.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:00 AM.