Lt. Commander
Join Date: Dec 2007
Posts: 120
# 31
05-16-2012, 01:36 AM
Quote:
Originally Posted by kolban View Post
Folks,
I have a dual core high end PC with 4 GB of RAM and a GTS 8800 nVidia card. I have just refreshed the drivers for it today. I am running Windows 7.

I am playing the game at 1280x900 and performance is awful. I am playing on the initial levels (borg and asteroid) and the game simply lags and jerks continuously. If I lower the resolution to ridiculously low

Neil
Perhaps you solved your issue regarding your GTS8800, but it very understandable that you can't play in high settings. The card is obsolete if you like playing in the new generation MMO's like STO, Guild Wars 2, The Secret War and Star Wars: The Old Republic.

E.G. if you like playing Ultra settings in The Secret War recommend is to get GTX550 or Radeon HD7700 or better. GTS250 1GB will do, but you have to lower some settings. Recommodation: upgrade Windows tot 64-bit so you can use 8GB, 32-bit OS has a limitation up to 4GB only!

Kind Regards,
Generix
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 32
05-19-2012, 02:40 PM
Ok sorry in advance for this long post. Not sure if this will help but I figured I would go ahead and post the settings that work extremely well for me. In both CO and STO, I used to get about 30fps max, and stuttering was awful in places.

With the following changes I eliminated all game stuttering, and now get smooth constant 60fps while still using maxed in game settings. (and my hair no longer disappears during beam up)

My system is about 3 years old: intel core2 quad 2.50ghz, 6gb ram, Nvidia GTS 250 gpu


1) In Nvidia control panel, under Manage 3D settings, go to program settings tab and add gameclient.exe (sto) to the program list where it says "select a program to customize".


2) Under that program settings tab, with Star trek online selected, set settings as follows:
Anisotropic filtering 8x
Gamma correction on
Mode: enhance the application setting
Antialiasing setting: 8x
Transparency off
Power management: adaptive
Ani sample optimization: off
Negative lod bias: allow
Texture filtering: quality
Trilinear optimization: on
Threaded opt: auto
Tripple buffering: off
Vertical sync: use application setting


3) Next on in game video settings, under Options, then Video:
I keep my display mode as windowed maximized, always making sure the game client resolution is same as my desktop resolution
Monitor vertical sync: On, half resolution: Off

Next: Uncheck advanced video settings, set slider to Low
Check show advanced video settings again, turning it back on

Set Anti-aliasing: 8x, dynamic lighting on, max lights per object and texture anisotropic filtering maxed out.
Lighting quality: High, Shadows: Off (shadows off is my personal preference)

Under Performance, Detail and Effects sections, all on/off toggles set to ON except for: screen space ambient occlusion and cinematic focus (depth of field) - these were personal preferences as they lowered my fps and imo game looks better without them.

Under detail: first two at 200%, next 3 are 125%, 200% and 125%. Max physics debris objects set to 100

Also under Performance, Detail and Effects sections, all drop down menus set to High except for reflection quality and shadows (again personal preference here). If you set bloom quality to high and keep it somewhere between 20-60% it looks awesome. No overkill on the glow.

Under Troubleshooting, options 2, 4, 5, 6, 7 all ticked on. Rest are ticked Off. Then scroll down to the bottom, set Limit Frame Rate to OFF, and set video memory limit to match the video memory of your Graphics card, in my case 1024mb.


NOTE: After making these changes, soft particles, ambient occlusion, depth of field and underwater view should NOT be greyed out. If you experience this just type: /bloomquality 3 in the chat window and close the sto client and restart it. They should then show as enabled.


Apply settings, close STO. (reboot if you have not done so in a while). Relaunch STO and type /showfps 1 to see your fps.

A friend of mine with a new computer is now getting 90-240fps with these settings, and it also eliminated his stuttering in game. My fps now stays at 60 majority of time, occasionally dips to 40's but no stuttering ever now and awesome performance and quality.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 33
05-19-2012, 06:00 PM
When this game was designed and tested, Cryptic were having issues when it came to nVidia cards when trying to get the best possible performance so they were working on the coding issues which seemingly appear to not have been totally solved given your unhappiness you've posted. I don't know if it was with certain card series or all in general.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 34
05-20-2012, 06:14 AM
Guys, things like 4 gig ram, GTS 8800, dual core, and the words high end pc weren't a clue? Peek at the date of the OP, 2-02-2010....you're giving zombie tech advice 27 months late.:p
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 35
05-20-2012, 08:15 AM
Quote:
Originally Posted by CapnBludd View Post
Guys, things like 4 gig ram, GTS 8800, dual core, and the words high end pc weren't a clue? Peek at the date of the OP, 2-02-2010....you're giving zombie tech advice 27 months late.:p
Never the less a Dual core shouldnt be a single problem, but it does depend on the speed of the Dual cores :p It should be overclocked for the best performance.

Problem with this game is that it only supports 2 threads, so more then a quad core will hardly gain you anything.

Also the HUD/GUI/UI of this game is being drawn by the processor and seems to be only drawn/showed by one CPU thread. So especially if there is alot of stuff on the screen, lots of ships, lots of reticles, etc, the game just slows down even i you have the fastest GPU around for $500+

I think this game would get alot faster as soon as the update this old UI and make it so that the GPU actually accelerates it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 36
05-20-2012, 12:26 PM
Quote:
Originally Posted by CapnBludd View Post
Guys, things like 4 gig ram, GTS 8800, dual core, and the words high end pc weren't a clue? Peek at the date of the OP, 2-02-2010....you're giving zombie tech advice 27 months late.:p
lol yea I saw. Just thought it might be helpful to post what I found for others who stumble upon this thread.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 37
05-25-2012, 06:30 AM
I have a gts 8800 640mb card which is a generation older. I have no issues running everything on max but antianalizing is set to like 4x. My system is windows 7 64bit 8 gig ram i5 2500k proc. my resolution is set to 1920x1200 Yea the card is old but its not totally out of date. the only time it slows down is when there is a ton of on screen graphics and it studders a little bit but nothing severe.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 38
05-26-2012, 07:34 AM
Quote:
Originally Posted by ericlw View Post
I have a gts 8800 640mb card which is a generation older. I have no issues running everything on max but antianalizing is set to like 4x. My system is windows 7 64bit 8 gig ram i5 2500k proc. my resolution is set to 1920x1200 Yea the card is old but its not totally out of date. the only time it slows down is when there is a ton of on screen graphics and it studders a little bit but nothing severe.
What kind of frame rate are you getting?
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:53 PM.