Go Back   Star Trek Online > Information and Discussion > The Academy
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
So I was just trying out the subsystem targetting of my new science vessel, and I noticed it seems to always put 1 or occasionally both phasers offline for about 12 seconds. I tried looking at the skill description in the "p" menu and also by mousing over, but it says nothing about side effects.

If this is on purpose than it seems a bit odd. The most ironic thing is when you "target weapons" to lower enemy damge, and it has a larger effect on your own weapons than the enemy's. Also annoying when I target enemy shields, they go halfway down, and then they charge back up while my beams are offline. What was the point in that?

I know "overload" puts your weapons offline, so my first thought was that this was a bug. If it's not a bug, than it should probably be added to the skill description as it's a pretty large side effect. Right now I have no idea how it determines which weapon(s) goes offline, or if there's anyway to reduce the amount of time, as this feature isn't even mentioned anywhere. (Or is it?)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-02-2010, 08:06 PM
During open beta I had a Science vessel and never observed this behavior. The "Target X subsystem" abilities go into cool down, but the phasers themselves continued to fire, but I haven't gotten to that level again since Head Start/opening day, so I can't say that it hasn't changed.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-02-2010, 08:07 PM
Yeah, I just got my Science Vessel today and noticed the same thing. It wasn't like that in OB, so I'm assuming its a bug. Seems like it's knocking out whatever weapon triggered the effect. Had it down for 4 seconds, then again for another 8 seconds.

Honestly it's made subsystem targeting pretty much useless. Sucks, I actually really enjoyed that in OB.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-02-2010, 08:41 PM
Quote:
Originally Posted by TripFour View Post
Yeah, I just got my Science Vessel today and noticed the same thing. It wasn't like that in OB, so I'm assuming its a bug. Seems like it's knocking out whatever weapon triggered the effect. Had it down for 4 seconds, then again for another 8 seconds.

Honestly it's made subsystem targeting pretty much useless. Sucks, I actually really enjoyed that in OB.
Aha! I thought so. It seems unlikely that there would be a "side effect" which pretty much negates the entire point of the skill, which isn't even mentioned in the description.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-02-2010, 08:51 PM
I had it happen in Open Beta a few times and bugged it. It would happen every now and then and put your weapons offline for between 4-8, maybe higher seconds. Was very annoying and I stopped targetting systems because of it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-02-2010, 08:56 PM
I've noticed this for quite some time now, I figured it was partly because I fired both phasers at the same time then moved out of one's firing arc as it was going through it's fire routine, then moved out of the other one's firing arc, thus the sitting down for the CD. Although, this was odd, I never really paid enough attention to it enough since i'm often staring at my aux power or managing torp positioning.

Personally, I'm more curious as to the mechanic behind the targetting subsystems buffs and whether or not it's possible to shut down the subsystem in question, but I digress, that's a discussion for another time...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-02-2010, 09:56 PM
I observed this in Open Beta as well as in live, though I actually assumed it was intended. It just means I don't bother to use the skills when I'm solo, only in groups when I'm not "DPSing" (ie max power to auxillary for extra science ability power).
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:22 PM.